While doing query from Query work bench getting 13014

While doing ‘select’ query on my Couchbase node getting error code 13014. However, I have given query_select permission on specific bucket. Also, tried from admin user but getting same error code.
Please help, Thanks

Could you show us your query, perhaps sanitized? Also, what buckets do you have? And what version are you running? How are you submitting the query?

@johan_larson Thanks for you reply. I am using query like Select * from bucket limit 10; from Query Work bench and I am having 2 buckets only. Currently I am using 5.5.2 EE version.

Give the grant permission and try again.


GRANT query_select ON bucket1, bucket2 TO usr1;

@vsr1, I have already given the permission for both buckets not only query_select others also.

Is it possible post the output of or check user that you trying has select privilege
SELECT * FROM system:applicable_roles;
SELECT * FROM system:user_info;

@vsr1, Thanks. Above query is giving the same error code 13014. However I am running the query from admin user which having all the permissions.

Not sure why you getting error.
You can try restart couchbase server and try it or kill cbq-engine process (it will start automatically) and try again.
If you have support agreement you can concat support. If not and try reinstall fresh and try it.

Okay…will restart and let you know. Thanks