Upgrading from Beta to Development 5.0

… has resulted in my Couchbase system totally useless. I have an endless number of this “closed” bug in my log file:

Service 'memcached' exited with status 134. Restarting. Messages: 2017-11-24T15:50:22.984695-04:00 FATAL /opt/couchbase/bin/../lib/libcbsasl.so.1.1.1(_ZN2cb4sasl9to_domainERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x111) [0x7fd136a63000+0x8641] 2017-11-24T15:50:22.984705-04:00 FATAL /opt/couchbase/bin/../lib/libmemcached_rbac.so.1.0.0(_ZN2cb4rbac9UserEntryC1ERK5cJSON+0x320) [0x7fd136c93000+0x6780] 2017-11-24T15:50:22.984716-04:00 FATAL /opt/couchbase/bin/../lib/libmemcached_rbac.so.1.0.0(_ZN2cb4rbac17PrivilegeDatabaseC1EPK5cJSON+0xda) [0x7fd136c93000+0x6b2a] 2017-11-24T15:50:22.984725-04:00 FATAL /opt/couchbase/bin/../lib/libmemcached_rbac.so.1.0.0(_ZN2cb4rbac21loadPrivilegeDatabaseERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0xd7) [0x7fd136c93000+0x7237] 2017-11-24T15:50:22.984738-04:00 FATAL /opt/couchbase/bin/memcached() [0x400000+0x1df8a] 2017-11-24T15:50:22.984764-04:00 FATAL /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7fd1346f3000+0x20830] 2017-11-24T15:50:22.984776-04:00 FATAL /opt/couchbase/bin/memcached(_start+0x29) [0x400000+0x155c9]

Running Ubuntu 16.0.3 LTS and ran apt update in the hopes that maybe some of these error messages might go away.

Everything was working fine until I tried to replace one drive with it’s larger replacement. Just another non-critical but new drive to replace an old one. The old drive did have an fstab/UUID entry but the computer refused to boot with the drive in it. Totally baffling.

I can’t even access documents in my buckets now. I guess I should have simply used the cbbackupmgr from the beta and hoped for the best. But no, I decided it was “safer” to install the latest database version. Not often I see an update rendering something inoperable.

… and people wonder why I can’t stand PCs. Frustration.

  1. Turns out that using dpkg to remove couchbase with -r option is equivalent to the -p. I thought that maybe removing Couchbase completely, then adding it back in would fix it and that -r would not remove my data files. Unfortunately, all my data has been flushed into the digital abyss.

  2. As for the errors, I ran apt both update/upgrade after a full reinstall (I also took the opportunity to make my boot drive GPT so I can auto boot to UEFI while headless). Turns out, I got the same error boot error as before. The installation was working perfectly until I performed a reboot and ended up with the same error. It’s the amdgpu fiasco all over again.

Now that the system is headless, I’m actually installing Ubuntu Server 16.0.4 LTS instead of the full desktop as it will no longer be required.

Seems 16.0.4 LTS updates have caused some funkiness.

1 Like