"Unable to locate node" error when using v1.3.12

I’m trying to use version 1.3.12 of the SDK to connect to my local couchbase server (3.0.1 Community Edition (build-1444) but not having any success. The problem seems related to reading the bucketStreaming url, which fails. The relevant portion of the logs shows this:

2015-05-18 13:45:45.6652|WARN|Couchbase.MessageStreamListener|Resolved pool url to 2015-05-18 13:45:45.6652|WARN|Couchbase.MessageStreamListener|Start receiving messages. 2015-05-18 13:46:45.7238|WARN|Couchbase.MessageStreamListener|ReadMessage failed with exception: 2015-05-18 13:46:45.7268|WARN|Couchbase.MessageStreamListener|Reached the retry limit, rethrowing. 2015-05-18 13:46:45.7268|WARN|Couchbase.MessageStreamListener|Current node '' has failed. 2015-05-18 13:46:45.7268|WARN|Couchbase.MessageStreamListener|Looking for the first working node. 2015-05-18 13:46:45.7268|WARN|Couchbase.MessageStreamListener|Could not resolve url; trying the next in the list 2015-05-18 13:46:45.7268|WARN|Couchbase.MessageStreamListener|Could not found a working node. 2015-05-18 13:46:45.7438|WARN|Couchbase.MessageStreamListener|All nodes are dead, sleeping for a while.

However, when using version 2.1.0 of the SDK in another project to store and fetch values from my couchbase server, everything works fine. The only problem is that the project I am working on is using v4.0 of the .net framework, which v2.0+ of the couchbase sdk doesn’t support. So, I either need to figure out why the 1.3.12 version is failing or perhaps compile the 2.0 version for the 4.0 framework.

@jmorris is this something you can help with?

Do you have couchbase installed on localhost? Can you reach from a browser?

2.0 uses features from .net 4.5, so this probably won’t work.


Thanks for replying Jeff.

Couchbase was installed on localhost and I was able to reach the /pools endpoint. The problem seemed to be in accessing the bucketsStreaming url, they would never respond (e.g. I read somewhere else that they are designed to be read as a non-buffered stream but even when I tried to access these endpoints with fiddler or my own .Net code, I never got a response back.

@wiseguyeh -

If you have fiddler running disable it; it it will conflict with the streaming API.


Hi Jeff,

Fiddler was disabled during my attempts, I was enabling it to troubleshoot why couchbase couldn’t connect.

I was able to fix, with the assistance of my glamorous colleague, this issue. The problem was that our AV solution was blocking the streaming connection. Disabling the AV allowed me to connect to couchbase.

1 Like