Failed to initialize pool

Hi, I’m trying out Couchbase for our company, and I’m not having much luck connecting using the .net SDK.

Connecting to http.//:8091/pools/ via a browser works fine, so the server is available, but when trying from our asp service I get “unable to locate node” as the response message when doing an ExecuteStore.

The trimmed code looks like this:

var config = new CouchbaseClientConfiguration ();
config.Bucket = “bucket_name”;
config.BucketPassword = “bucket_password”;
config.Urls.Add (new Uri (“http://:8091/pools”));
cbc = new CouchbaseClient (config);

var result = _cbc.ExecuteStore (StoreMode.Set, “object_key”, object);

Pretty standard stuff. I’ve also tried running the app on the Couchbase machine using and localhost in the uri with the same results. I’m using the newest stable version of everything on MS Server 2012.

Log shows this:

2014-05-26 13:22:02.7238|WARN|Enyim.Caching.MemcachedClient|Creating new client. CID: c7c59dc7-0f52-46bd-a2c4-8ed889926cf6 CouchbaseClient
2014-05-26 13:22:02.7497|WARN|Couchbase.CouchbasePool|Starting Couchbase.CouchbasePool
2014-05-26 13:22:02.7674|WARN|Couchbase.MessageStreamListener|Started working.
2014-05-26 13:22:02.7674|WARN|Couchbase.MessageStreamListener|Starting the listener. Queue=True
2014-05-26 13:22:02.7770|WARN|Couchbase.MessageStreamListener|Looking for the first working node.
2014-05-26 13:22:03.2293|WARN|Couchbase.MessageStreamListener|Resolved pool url to
2014-05-26 13:22:03.2293|WARN|Couchbase.MessageStreamListener|Start receiving messages.
2014-05-26 13:22:03.2706|ERROR|Couchbase.CouchbasePool|Failed to initialize the pool.
2014-05-26 13:22:03.2763|WARN|Couchbase.MessageStreamListener|Processing message: {“name”:“our_bucket_name”,“bucketType”:“membase”,“authType”:“sasl”,“saslPassword”:“password”,“proxyPort”:0,“replicaIndex”:false,“uri”:"/pools/default/buckets/our_bucket_name?bucket_uuid=88ecde59b0e41d255e7a845583d3c2c8",“streamingUri”:"/pools/default/bucketsStreaming/our_bucket_name?bucket_uuid=88ecde59b0e41d255e7a845583d3c2c8",“localRandomKeyUri”:"/pools/default/buckets/our_bucket_name/localRandomKey",“controllers”:{“compactAll”:"/pools/default/buckets/our_bucket_name/controller/compactBucket",“compactDB”:"/pools/default/buckets/default/controller/compactDatabases",“purgeDeletes”:"/pools/default/buckets/our_bucket_name/controller/unsafePurgeBucket",“startRecovery”:"/pools/default/buckets/our_bucket_name/controller/startRecovery"},“nodes”:[{“couchApiBase”:“",“replication”:0.0,“clusterMembership”:“active”,“status”:“healthy”,“otpNode”:“ns_1@”,“thisNode”:true,“hostname”:“”,“clusterCompatibility”:131072,“version”:“2.2.0-837-rel-community”,“os”:“windows”,“ports”:{“proxy”:11211,“direct”:11210}}],“stats”:{“uri”:"/pools/default/buckets/our_bucket_name/stats",“directoryURI”:"/pools/default/buckets/our_bucket_name/statsDirectory",“nodeStatsListURI”:"/pools/default/buckets/our_bucket_name/nodes"},“ddocs”:{“uri”:"/pools/default/buckets/our_bucket_name/ddocs"},“nodeLocator”:“vbucket”,“fastWarmupSettings”:false,“autoCompactionSettings”:false,“uuid”:“88ecde59b0e41d255e7a845583d3c2c8”,“vBucketServerMap”:{“hashAlgorithm”:“CRC”,“numReplicas”:1,“serverList”:[“”],"vBucketMap”:[[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],[0,-1],

2014-05-26 13:22:13.2385|WARN|Couchbase.MessageStreamListener|HB: Pinging current node ‘’ to check if it’s still alive.
2014-05-26 13:22:13.2390|WARN|Couchbase.MessageStreamListener|HB: Trying ''
2014-05-26 13:22:13.2811|WARN|Couchbase.MessageStreamListener|HB: Node ‘’ is OK

This output is confusing. It seems to find the Couchbase server but not the bucket, yet it’s referring to the bucket with the right UUID…

Samal -

What’s happening is that the client is bootstrapping, but cannot establish the final streaming connection to the Couchbase server. Usually this happens when you are running an HTTP debugger like fiddler or a firewall is blocking the connection.

Here is a similar issue:

Check to see if that is what’s causing the issue and let me know how it goes!


Hi Jeff, thanks for the answer.

I changed the IP in the code to, published my Nancy/ service and run it on IIS on the same machine as the Couchbase server, and turned off the firewall. There was no anti virus/malware software or debugger like Fiddler to disable. So this should cover about everything I’ve found in that thread to linked to. Still the same results unfortunately.

I’ve also tried building/launching from both VS 2012 and 2013 on Win 7, and even Xamarin Studio on Mac OS. No difference.

Then I installed Couchbase on my development machine, and that worked right out of the box. So the issue is on the server machine not the development machine.

So one thing I’m wondering is if it is ok, that the Server Node Name on the server is, as I’m seeing this exception in the intelliTrace panel when breaking right after running ExecuteStore():
“IPv4 address and IPv6 address ::0 are unspecified addresses that cannot be used as a target address.”"

samal -

This looks suspiciously like a bug; can you create a bug ticket in jira so that we can “officially” track this?

If you create the ticket, you’ll get update emails, so probably the best way to go if you want to know the progress. Feel free to add as much information as possible and keep updating the ticket as needed.