Two errors running localhost (error parsing failed and unknown N1QL error occurred)

UnhandledPromiseRejectionWarning: Error: unknown error : error parsing failed and unknown N1QL error occurred. This is usually related to an out-of-memory condition.

I see these two errors on localhost with CB 5.5.1 and SDK 2.5.1 on MacOS MoJave. Since neither view queries or n1ql queries will work I am assuming I have a setup issue. However, everything works great in the web UI (view queries and n1ql queries). Any assistance would be great, I’m not getting anything useful from the errors in NodeJS.

Has 5.5.x introduced a lot of problems? I never had these issues with previous versions of CB and it’s SDK. It’s always been rock-solid, slightly bummed…

Thanks for any input,


After further experimentation I have found that this is somehow related to the host OS that I develop on. It’s MacOS Mojave, recently updated. I deployed this same code to ECS (Amazon Elastic Container Service) and it worked just fine. Additionally, I ran the code on a Windows vm where it also worked just fine.

I am not certain as to why this code will not execute properly on my Mac, however, I’d be willing to post any intel that might help track down the issue. Should I start by studying the node-gyp output that comes from doing an npm install of the couchbase lib?



Hi @corey_perkins, thank you for offering to help track down this issue. We’ve been seeing intermittent problems along these lines with Mojave.

One theory we have is that the problems relates to the limits on the number of max processes or open files. What do you see when you type:

launchctl limit

Does the behavior change any if you specify higher limits in /etc/launchd.conf (reboot may be required), e.g.:

limit maxproc 2048 4096
limit maxfiles 1024 unlimited

@eben glad to help! I kicked up the limit but I am still seeing the same errors on my Mac. I attached before and after pics of the output from launchctl limit.



Darn, back to the drawing board. I will think about it and see what else we can suggest. Thanks for trying it out!

@eben can you assist us?


I fixed my problem. Uninstalled Node 11 and used nvm to install Node 10.13.0 LTS. I should have pegged that earlier, but thanks for the help anyway!


1 Like