Timeout errors in logs

We’re seeing a bunch of errors like this in our logs - is there a timeout setting we should be adjusting?

Clients are using the php sdk or and some are using client side moxi - as best we can tell the errors correlate with failed connection attempts by clients. Everything is in the same aws zone and the couchbase servers are provisioned with the extra iops setting. Normally we run a pair of enterprise servers taking advantage of the free tier, right now I threw two more on their to see if it made a difference - it didn’t so I’m I’m going to balance them out again tomorrow.

There are 5 buckets, 2 memcache and 3 couchbase. The logs bucket which seems to be the problem is mostly of increment calls - about 100/sec (we keep a counter for each page/hour and increment hits)

Server error during processing: [“web request failed”,
{mochiweb_http,headers,5}]}] (repeated 1 times)

Solved. There was a bad machine in the cluster. No errors reported at the aws or system level, newrelic didn’t report issues and the couchbase errors logged were not associated with any one machine. However when we rebalanced that machine out and replaced it with an identical one (from the same ami) the error messages stopped.

Best guess is the server amazon allocated has some underlying connectivity issue (it was an m2.2xl in use west 1c if anybody cares )


Yes you can set the timeout for the operation using the method call:

You can see the list of operations here:

Basic test is available here:

This is related to this section in the developer guide:

Note that your errors are probably related to a cluster/network issue, setting a larger timeout will just “hide” the issue.