Server setup issue


I’m trying to test Couchbase.

On my brand new Couchbase server, I’m getting the following error message when trying to create a new document in the web interface by clicking

Data Buckets -> (Bucket Name ->) Documents -> Create Document
In the popup where I enter the ID of the document pressing OK results in


Now in case this is not enough information about the issue, here are more details:

compiled Couchbase 2.1.0 from sources on Debian 7.1 (due to licensing reasons, seemed to have worked fine)

For a first test I just start Couchbase as root:
cd /usr/src/couchbase/install/bin

Results look fine:
"Erlang R15B01 (erts-5.9.1) [source] [64-bit] [smp:2:2] [async-threads:16] [kernel-poll:false]

Eshell V5.9.1 (abort with ^G)

Accessing the web interface on server:8091 using Chrome works fine as well. Initial setup looks OK. No sample databases created.

To reproduce the issue I have deleted all Buckets, then created a new Bucket, named it, type Couchbase, other values were left default (RAM Quota: 601MB, Std Port: 11211, Replicas: enabled, workers: 3)

Problem reproduced.

Searched for this issue, found one posting which wasn’t solved but OP didn’t provide additional infos.

Any hints?

Thanks in advance!


Do you still have the issue?

What is the issue with the licensing of Couchbase Server for you environment?
Have you tried the Community Edition?


Issue was solved (workaround) with help from Aliaksey Kandratsenka in
Licensing the couchbase server is not an option, because of the … license (not an apache license)!