Production Views not indexing or returning results

I have a bucket (Couchbase 2.0, single instance development ‘cluster’) that I populate from a production stream of messages. There are in the region of 80K items in the bucket and the total disk size (including views is around 500MB. This is a tiny fraction of the dataset that we’d like to use in production.

Now if I create a map/reduce view and test using the Development Time Subset, I can see sensible looking results. However, if then publish the view and run the production version, I get no results when I query.

There are overlays on the view screen indicating that indexing is in progress. These seem to jump around though from around 2% to around 40% but never get any further. CPU for the erl.exe process is running at around 25% CPU and I can see the size of the view data on disk stat growing.


I think that the indexing of the document (the full dataset) is not done this is why you do not have any result. Once the indexing has been done once on the full dataset, the indexing is incremental.

Can you wait for a while and see if the result is better?

When you use a "Subset of the data, the view is only indexing few documents to let you test your view.

Some interesting pointers:


Simon, I’d also strongly recommend you to upgrade to and use the 2.1 version of Couchbase Server. It’s possible that you’re running into a known issue that was blocking index updates when a document didn’t contain a field that was being emitted by the view.

Can you share your view definition(s) and sample documents?


Thanks Perry - will try this and let you know.

Hi - the indexing is still not complete over 12 hours later (and still no results) so I’m going to look at the issue Perry is referring to above and upgrade to v2.1.