Problem installing couchbase server on windows

I have a problem installing couchbase server on windows 10.
I had couchbase installed like 2 months ago and everything worked well.
But since maybe an update of windows, nothing works.
There’s one time I tried to uninstall and reinstall and it worked.
But this time this method doesn’t work anymore and it gives me a message saying the Microsoft Universal C Runtime must be installed.%E6%9C%AA%E5%91%BD%E5%90%8D%E5%9B%BE%E7%89%87
Is there anyone has the same problem?
Thank you for any help!!

Hi @fuchaogui. You may need to reinstall the Microsoft Universal C Runtime from here.

Hi, thank you for your reply.

I’ve already tried these, these updates are for lower versions of windows
I’m using windows 10.
Couchbase worked on my pc like one week ago and stopped working after updating.
So maybe it’s something about the update.

Hi @fuchaogui. I thought that page was for Windows 10 - it does specify that it’s a download for “Windows 10 Universal C Runtime”. Maybe you can get it from Windows Update instead?

It seems that Windows 10 has already the windows 10 Universal C Runtime installed