Problem getting started with .Net SDK 3.0

I am trying to get going with the .Net 3.0 Beta but are not having much luck. I have a project where i would like to write some data to couch base server. But since there is no formal docs on how to use the client in VB.Net i tried to give it with C# a try with no luck either. I tried the Github stuff as well as what i found in beta Docs.

  var options = new ClusterOptions()
                .WithCredentials("username", "password")

            var cluster = new Cluster(options);
            var bucket = await cluster.BucketAsync("bucket-name");

            var collection = await bucket.DefaultCollection();

            var upsertResult = await collection.UpsertAsync("my-document", new { name = "mike" });
            var getResult = await collection.GetAsync("my-document");

when doing so i get 2 Errors

|Error|CS1729|'Cluster' does not contain a constructor that takes 1 arguments|CouchBase C|
|Error|CS1061|'ICollection' does not contain a definition for 'GetAwaiter' and no accessible extension method 'GetAwaiter' accepting a first argument of type 'ICollection' could be found (are you missing a using directive or an assembly reference?)|CouchBase C|

When i set up the cluster like the below the error goes away
var cluster = new Cluster("couchbase://","Administrator", "password");

Is there a better Doc avail as i feel it shouldn’t be that hard to get connected to the Couchbase via .Net client

@makeawish -

Hi, looks like you found some changes in that occurred in the Beta that haven’t been reflected in the docs! I created a ticket to update the documentation here. Thanks for reporting; they should be updated shortly.