PHP SDK v2 not working in Windows

My configuration is as follow

  • PHP: 5.5 VC11 x86 ZTS
  • Couchbase Server: 3.0.3

I tried using several version of extension from this link

But none of them are working. When I try using PHP 5.5 VC11 ZTS x86 extension, php_error.log shows no error but all PHP page don’t load. When I try php -m, I get a message The instruction at 0xsome_val referenced memory at 0xsome_val. The memory could not be read

I cannot find any other log or helpful information. Note: when I tried using PHP SDK v1, it worked perfectly in one attempt and I could see it in php_info()

For future readers, I updates PHP to 5.6. and got the latest extension and it worked for me


@brett19 any other advice you can give here

Please can you help me anyone,
im using windows 7 so i installed couchbase server and then how can i configure the C SDK and where i want to configure but i downloaded PHP SDK from and C SDK from
if i extract c sdk i got one folder after that what i want to do?

Please reply me as much as possible