No service on port 11211 with Couchbase Server 5.x

I have a strange error on an upgraded 5.x couchbase testserver.

It seems that my Memcached bucket is not available on port 11211 anymore and I’m not able to find out why. When I re-add it also no service starts running on port 11211.

Any idea ?

Couchbase Data service listens on 11210 port.

Moxi has been deprecated and is not used anymore. This is why you might not see 11210.


I saw it in the Json config files indeed. So using port 11210 should work ? I also see a 11209, both are in use I see, is this an alternative one ?


11209 port is reserved for Couchbase needs.
This page describes all ports related to the server

Thanks for the link and the update, it’s always good to review everything when you want to release/upgrade software @ the same time.

Strange thing is, I can connect to 11210 using telnet but using a user that has rights to the bucket I get a:


Any idea how to debug that ?

Have you tried our official client libraries? 11210 unlike moxi requires from SDK extra work because requests to this port are not rerouted to other cluster nodes, so that the client have to be aware of Couchbase, and legacy memcached clients will not work.

I’m confused here, why is the native php-memcached library not working, I thought it should be compatible as that is the power of it ?

For coucbase itself I’m using the SDK, which works great, but I’m not sure about the couchbase memcached libraries, so they replace the php-memcached ones ?

php-memcached library written for memcached server. Although Couchbase uses memcached protocol, it provides much more features. And this is why we maintain php-couchbase module. This is the recommended SDK to be used with Couchbase in production.

OK, so for software that uses memcached itself and I want to use couchbase as it’s “memcached” server I need to remove php-memcached and only install the SDK, which is already installed.

That is what is not clear to me.

php-memcached worked pretty well back the daus on 3.x and 4.x but on 5.x it fails indeed.

Couchbase is not memcached. When you used Couchbase as memcached in the past you actually used moxi proxy to Couchbase which has its own performance issue being single entry point of the cluster.

OK, but what is the “fix” here as the advantage was to have a replicated Memcached server which Couchbase also communicated into the public compared to normal memcached servers.

So if Moxi is deprecated, what’s the solution here then ?

I don’t see any.

You can follow advice from the server release notes: use client-side moxi.

I have read about that indeed and sounds like a plan.

Will the moxi packages be build/supported the same as for 4.x was done ?

I still see it by running Docker image couchbase:5.1.1.

Hi folks,

I am struggling with client-side moxi as I am quite new to couchbase and moxi proxy. But as it is stated in the above link using cb 6.0 it would be quite a nice solution for using a couchbase cluster and have a memcached drop replacement using moxi.

First of all, where am I able to find the latest moxi proxy as I have found only an years old moxi-github and read about newer moxi releases.



Still not seeing this in Couchbase 7, so I went ahead and opened a ticket for this since there: [MB-49116] Please reconsider adding Moxi for localhost:11211 applications - Couchbase database

There are still valid scenarios where this is both needed AND can be done securely. See that ticket for details.