Moxi server does not respect bucket password

I’m using Couchbase server v4.1 community version. And the setup is the client side proxy deployment strategy. There are 2 questions for the client side configuration. In the moxi.cfg file

  1. There are only options of USR and PWD, but there are no options for specifying bucket password, even if I set a password for that bucket. Is there a way around this?
  2. Since Couchbase v4.1 only has admin and non-admin view-only roles, that indicates we have to use the administrator credentials in moxi.cfg to get access. Is that what I’m supposed to do?


Have you been able to fix this ?