Issue With The XDCR


We are using Couchbase cluster having 4 nodes with below configuration:
Couchbse Server Version: 3.0.1
OS: Linux
RAM Quota Per Node: 25 GB (Used: 15 GB) - So total cluster RAM Quota is 100 GB
Disk Space Per Node: 100 GB (Used: 20 GB)

We have one Bucket in this cluster having following statistics:
Total Documents: 70000
Data Space On Disk: 4.5 GB
RAM: 28 GB allocated to Bucket but 18 GB is used (100% documents are in RAM)

Now when we are using XDCR (Version 2) to transfer this Bucket data to another cluster, we are having problems that one of the node from this source cluster is taking 100% RAM.
This is causing memory swap and sometimes the Node failover in Couchbase cluster. We are not sure why XDCR is using so much RAM.

Can anyone please help us here ?


We are using Couchbase test cluster with 4.0.4 community version. Getting an error while creating replication. “cannot find remote cluster err = Failed to connect to cluster reference remoteCluster” .

We have created cluster reference with IP address and cluster name. When we tried to create replicate from source “Bucket1” To destination Bucket named it as “Bucket 2” Getting the above mentioned error. We logged in those servers and tried telnet it is connecting without any issues.

Please help on this.

Thanks in advance.

Hi @pravepavi,

Have you been able to resolve the issue since then?