Index/View blocked/not working and nothing in logs


On Ubuntu 14.04
Community Edition 3.0.1

Since we upgraded our development server from Community Edition 2.2.0 we had following serious problems:

  1. View/Index stopped working on a specific bucket: even the number of rows isn’t retrieved in the Console?
    1 Design with 3 views on this bucket, all of them stopped working.
    We tried the 3 different stale options but nothing helped, even stale ok!
    We republished the design view with or without deleting the production view but didn’t help.
    We restarted the server.
    The only thing that helped was adding another view to the design and magicaly views worked again.

  2. set stale false never return rows
    Removing views on another bucket magicaly returned everything to normal

In both cases we searched the logs for some alerts/warnings but didn’t find any!!??

I understand Community Editions are not stable releases but I expect at least to find some alerts in log files when indexes stop working?

We never had “non working” indexes/views with the Community Edition 2.2 (more then 1 year in use).
Those problems occur only after a couple of weeks with the 3.0.1 version?