Illegal bucket name configuring sync_gateway

I’ve created a bucket named “5minxte” in couchbase server, it was correctly configured and reachable through couchbase server REST API. Then, I was trying to configure sync_gateway to connect to this bucket, but the following error was thrown: 400 Illegal bucket name.

So, I’ve created a new bucket named “ale_minxte” in couchbase server and this time sync_gateway is connecting with no errors.

I can’t find any reference to “naming conventions for buckets” in guides and manual, even if I think it’s worthy to be clearly specified somewhere (at least during couchbase server configuration thought web interface).

Thank you for this amazing server!!

Best regards

Which version of Sync Gateway are you running, I just tried successfully with latest master and the following sync gateway config.

    "log": ["*"],
    "databases": {
        "db": {
             "server": "http://localhost:8091",
             "users": {
                 "GUEST": {"disabled": false, "admin_channels": ["*"]}


I’ve installed couchbase-server-community-4.0.0-centos7.x86_64.rpm and couchbase-sync-gateway-community_1.2.0-79_x86_64.rpm on a red hat enterprise edition 7.2. Differently from your configuration i’ve used “5minxte” also as “databases” key.

As soon as possible I’ll retry to use the old name to verify where the problem effectively was.

Thanks for your reply!