"Failed to create bucket" message during CB 3.03 install

Hello everyone,

I am trying to install CB 3.03 on Ubuntu 14.04 hosted on Terminal.com and I’m running into a major issue. To prepare the environment, I ran a script to open the appropriate ports on the host, then downloaded the Ubuntu install package, ran the installer, and launched the first run wizard at localhost:8091. Everything seemed to be going well until the last step of the installer and it kicks back this error message: “Failed to create bucket, request return an error.”

When I go into the Data Buckets section and attempt to create a bucket manually, I will inevitably receive the exact same error message. Now at first I thought this might be a disk space issue as the default Terminal.com environments only give you 10 GB but I increased the size to 20 GB, which has given me no issue in the past when running VMs locally and still got the error message.

Already posed this question the IRC channel and no one seemed to know what would cause such an error message. I spent a long time browsing the logs directory but could not find anything which seemed relevant to the issue. Any help here would be greatly appreciated.


Hi, Do you know what instance_type you’re using on terminal.com and does it meet minimum couchbase requirement?
Also I wanted to mention for Couchbase Server 3.0.3 we don’t support Ubuntu 14.04 but for our upcoming next major release 4.0 we will support Ubuntu 14.04.

Although you mentioned you ran a script to open appropriate ports on the host I would recommend following documentation to make sure all the ports are opened -

Hope this helps!

Anil Kumar

Thank you for the response Anil.

I am using an “xlarge” instance type so it should have 4 CPUs and 6.4 GB of RAM. I also adjusted the disk space up to 20 GB. The Couchbase network guide that you linked to is the exact guide that I followed when making the script to open ports and I confirmed they are opened and listening using nmap. I also installed CB 3.03 onto Debian 7 and Centos 6, both of which are listed under the supported platforms and still received the exact same error.

Zach Piazza