ERROR: unrecognized arguments: --bucket-port


I’m trying to edit an existing bucket to change the port to 11202. This bucket was initialized via GUI and the port couldn’t be set. I found out that bucket-edit option gives you --bucket-port option to change the port. However, when I tried editing the bucket I get an error. Please assist.

./couchbase-cli bucket-edit -c $HOSTNAME:8091 -u username -p password --bucket bucketname --bucket-replica 1 --bucket-port 11202
ERROR: unrecognized arguments: --bucket-port 11202

Couchbase version: 5.1.1

Hi Ghaleez,
Thanks for using our products.
I will try to reproduce your issue. What is your Couchbase edition you are using? Enterprise or Community?

Hi Thuan,

Thanks for looking into it. I’m using Community Edition 5.1.1 build 5723

Thank you

Hello @ghaleez ,

Just to be clear the --bucket-port argument is to configure server side Moxi. Which had been deprecated and has been removed in the newer versions of Couchbase Server. Moxi is used to support legacy memcached clients, if the Official Couchbase Server SDKs are being used then port 11210 or 11207 for TLS will always be used.

If you are looking for away to configure a bucket to listen on a port then this is not the way to do it.


Hello Patrick,

Thanks for the reply. I am actually looking to convert the bucket to be used for moxi. I have existing buckets in other cluster that are configured to be used for moxi running on port 11202. --bucket-port works with bucket-create upon initial creation but not with bucket-edit. I don’t want to destroy and recreate the bucket so wanted to use the bucket-edit option to reconfigure the bucket to be used for moxi.

Thank you

curl -v -X POST -u username:password -d ‘name=bucket_name’ -d ‘replicaNumber=1’ -d ‘proxyPort=11202’ http://:8091$HOSTNAME/pools/default/buckets/bucket_name

This worked. Changed the bucket port to 11202