ElasticSearch Replication via XDCR with Docker

Hi There,

I’ve a Couchbase Server (4.5.0-2601 Community Edition (build-2601)) setup on a single development machine which has some data in it. This server works inside a Docker container and had the container’s IP address as hostname.

I installed ElasticSearch on another server (again as a Docker container) and tried to get replication working. However I’m getting the following errors:

Attention - 2017-06-19 12:19:09 dev-01.sandbox.alperkan.at:capi_f4268e62702130298bf87f17cc481219/demo/demo_127.0.0.1:9091_1:dial tcp getsockopt: connection refused
Attention - 2017-06-19 12:19:09 dev-01.sandbox.alperkan.at:Pipeline f4268e62702130298bf87f17cc481219/demo/demo failed to start, err=map[capi_f4268e62702130298bf87f17cc481219/demo/demo_127.0.0.1:9091_1:dial tcp getsockopt: connection refused]

I’ve found a similar post on the forums so I tried to set a hostname on Couchbase Server using the REST API. I put the hostname in its /etc/hosts file like below:       localhost  dev-01.sandbox.alperkan.at

I was able to set its hostname. So I installed and configured ElasticSearch according to the instructions here. I added ElasticSearch server as a cluster in Couchbase and when I trigger the replication I still get the above error. ElasticSearch is installed on another server with another hostname: dev-02.sandbox.alperkan.at so I can’t understand why Couchbase tries to connect to the localhost for replication.

Any ideas?

1 Like

I have the same problem with the same version.