Need help - xdcr replication to ES stopped

Hi All,

Its very important and I need help here. I have tried searching but couldn’t find any useful replies. We are working on a huge volume data and has xdcr setup in place, suddenly couple of days ago, xdcr replication stopped saying can not find remote cluster reference.
We are currently using CB 4.0.0 and ES 2.1.1, elasticsearch-transport-couchbase plugin version 2.2.1 as stated by David.

I have tried to create new replication and I am getting below error message.
cannot find remote cluster err = Failed to connect to cluster reference remoteCluster/QHxZC2K7-mS1R_fok2ZSB6tCt62svuUezOtENnK9wwQ=

I have collect information I can upload. Its very important for me, please help.


I have another un used index on my ES, I tried creating replication to that bucket and I could create, now I tried creating replication again and to my surprise I am able to create.

New problem, now its throwing replication error saying “No source nozzle can be constructed since the source kv nodes are not the master for any vbuckets” on a specific node

any idea ?

I have closed the other unused index surprisingly CB XDCR started throwing cannot find remote cluster reference, this is a surprise, I am not replicating anything to that bucket. I reopened it, its started replicating, I cant guess why, any idea ?

Right now same issue is happening with me where I am trying to create replication between elastic search VM and couch base . It is throwing error :- cannot find remote cluster err = Failed to connect to cluster reference remoteCluster/tSuocSQaJUkgl-BdFw–3a0DfS7PZtm9iED0YlYIjv0.

I am using following guide :-

And I am on create replication step.

There is an issue logged for it

Does anybody have an Idea what it is ? and if it is something when it can be resolved?

Is there any work around for it? Does elastic search works only when it got a local node with it?