Couchdb error 500 adding new user

We have been using couchdb 2.1.1 as our back end database for several months now. We set up an installation using a bash script I wrote for RedHat or CentOS 7.4+ systems. We require a secure password for the admin user, and compaction is enabled in our local.ini.

Sometime in the last few weeks, the installation using the same scripts now fails to function on new CentOS VMs as we cannot add a new user to the _users database. The operation generates an error 500 and no other explanation. Even the example in the CouchDB online manual (section 1.6) fails (password x’d out):

[solarflare@localhost ~]$ cat newcdbusr

curl -X PUT http://admin:xxxxxxxx@localhost:5984/_users/org.couchdb.user:jan
-H “Accept: application/json”
-H “Content-Type: application/json”
-d ‘{“name”: “jan”, “password”: “apple”, “roles”: , “type”: “user”}’

[solarflare@localhost ~] ./newcdbusr {"error":"unknown_error","reason":"undefined"} [solarflare@localhost ~]

I went back and used an older CentOS minimal build (1618 I think, vs 1708 and 1804) that had been working for a long time, but that one also fails now. the installation script installs a series of packages that our software requires, along with erlang and couchdb (from the RH yum repos).

I have a gist of a diff between our local.ini and the distribution version at if that helps.

The last time I tried this, I noticed that httpd was not running, but even after ‘sudo sytemctl restart httpd’ and verifying that it is running, the couchdb user add fails (same error).

I’m not a couchdb expert, and I’ve only received a couple of questions about our installation on the couchdb slack channel.

Any pointers would be most helpful.


Hey, this forum may be the wrong place for CouchDB-specific questions, as Couchbase and CouchDB are different products.

You may find a better answer at Stack Overflow, or the couchdb mailing lists:


(This is what came up in my Google search…)