Couchbase Server stopped working

Good Morning!

I hope this isn’t some kind of duplicate. I did some searching, and so far everything I can find is that this is an old error, but last week my 4.5.1 stopped working on my windows 10 x64 box. I’ve tried installing everything up to the newest version, and the service refuses to start. I’ve tried removing/re-applying updates etc.

The text I am seeing in my event logs is:
Faulting application name: erl.exe, version:, time stamp: 0x58ed2300
Faulting module name: beam.smp.dll, version:, time stamp: 0x58ed22a9
Exception code: 0xc0000409
Fault offset: 0x00000000001751c0
Faulting process id: 0x58f8
Faulting application start time: 0x01d4801c1fe3c9e0
Faulting application path: C:\Program Files\Couchbase\Server\erts-\bin\erl.exe
Faulting module path: C:\PROGRA~1\COUCHB~1\Server\ERTS-5~1.1\bin\beam.smp.dll
Report Id: 2b38177d-1ca3-4981-9463-a0b52794191a
Faulting package full name:
Faulting package-relative application ID:

For older versions (4.5.1) the faulting module patch is c:\windows\system32\msvcr100.dll I believe. One of the visual C++ libraries.

I’ve seen posts for this error, but everything I see says it was fixed back in v4.5.1, so I’m a bit confused why I would just start seeing this now.

Can anyone think of any recent Microsoft patch that would have caused this (maybe I missed on in searching and removing them). Or perhaps a domain/system policy restriction that would cause this?

Thanks for any help!