Couchbase lite support for UWP


  Does couchbase lite supports UWP ? Can someone guide me to the dll's if it supports. I tried installing from NuGet Packages and it failed.

Not yet. Our goal is 2.0 for UWP support. It requires a lot of refactoring and getting rid of some third party deps. You can see a discussion here

okay, i was trying to see wether i can use the feature/uwp branch from the github. But when i was building it, i was getting a weird error

Severity Code Description Project File Line Suppression State
Error CS1566 Error reading resource ‘version’ – ‘Could not find file ‘C:\Users\AJAY\Downloads\couchbase-lite-net-feature-uwp\couchbase-lite-net-feature-uwp\src\Couchbase.Lite.Shared\Properties\version’.’ storage.systemsqlite.uwp C:\Users\AJAY\Downloads\couchbase-lite-net-feature-uwp\couchbase-lite-net-feature-uwp\src\StorageEngines\SystemSQLite\storage.systemsqlite.uwp\storage.systemsqlite.uwp\CSC 1 Active

Where as i couldn’t see file called version in any of the folders. Am I missing anything. Please help @borrrden

That file should be autogenerated at build time. It contains the version information to be embedded into the DLL. I don’t know why a UWP project would ignore it. You can generate it manually by running the GitVersion.exe file found in Tools in the root of the repo like this:

GitVersion.exe <path\to\repo> <path\to\repo\src\Couchbase.Lite.Shared\Properties\version

@borrrden I have tried to generate it manually as per your comments and still I’m seeing the same error on build :slight_frown:

Below is the response of the command line

C:\Users\AJAY\Documents\couchbase-lite-net\Tools>GitVersion.exe C:\Users\AJAY\Documents\couchbase-lite-net C:\Users\AJAY\Documents\couchbase-lite-net\src\Couchbase.Lite.Shared\Properties\version

The program I made doesn’t output anything, I think you have a different program named GitVersion.exe in your path and that is running by mistake. First of all, the actual path is the GitVersion folder inside of the Tools folder, so run it from there and make sure you are running the one in that folder.

It worked thank you :slight_smile: @borrrden