Couchbase lite cannot be build on macOS Catalyst

The CouchbaseLiteSwift pod does not build on macOS:

building for Mac Catalyst, but linking in dylib built for iOS Simulator, file ‘…/Pods/CouchbaseLite-Swift/iOS/CouchbaseLiteSwift.framework/CouchbaseLiteSwift’ for architecture x86_64

Does anyone know if that is fixable or will there be a update on the pod soon?

are you picking iOS Couchbase Lite libraries to build macOS? there are macOS Couchbase Lite libraries available, you may have to download the try. the libs for macOS and for iOS can not mix and match.

I have both, the iOS and the macOS lib in the pod folder. How can I decide what library is used? The application has to run on iOS and macOS.

It seems to there has been a discussion about this already. When will we see the official release that fixes this or is there now one official way to fix this: IOS CBL and Catalyst

Just do see if it would build I changed all the lib search paths for Couchbase to ../Pods/CouchbaseLite-Swift/macOS/........ After doing so the build would try to link with the macOS libs, but unfortunately that gives a similar build error.

Module 'CouchbaseLiteSwift' was created for incompatible target x86_64-apple-macos10.11

It appears CouchbaseLiteSwift (Pod?) does not provide a Catalyst compatible lib at this time.

Is anyone working on that? I tried it with the ‘CouchbaseLite’ pod too but same issue here. There has to be a way to build cbl for macOS. Does that mean no-one uses cbl on mac-os apps?

Does anyone know when someone will be working on that? Because if we cannot use the cbl database on macOS, we have no choice but to stop working with Couchbase. I am confused because there is actually a macOS folder in that path, I hope there is any way to make this work.

macOS works, iOS works, Catalyst is :man_shrugging: @jayahari.vavachan Might know more

Are you planing to make that work? I believe this will become more and more important

I tried to build it on mac only on a blank project. Other problem here:

Contents/Frameworks/CouchbaseLiteSwift.framework: unsealed contents present in the root directory of an embedded framework

Command PhaseScriptExecution failed with a nonzero exit code

It seems Couchbase does just not work on macOS?

Catalyst is not a high priority right now, but we will look at it as soon as we can.

You can use this Jira ticket(to view progress). If there is any update happened, will update it CBL-399

Is there any updates on official Catalyst support?


Yes- Catalyst support is available in Couchbase Lite 2.8.4. This is distributed as .xcframework via our downloads page or via Swift Package Manager.