Couchbase HTTP endpoints failing to start on aarch64 (7.1.0)

Most of the couchbase HTTP endpoints are not working when using the community-aarch64 docker image. I have tried exposing the ports, running docker in host networking mode, and even entering the container and using curl there - the results are the same regardless.

Based on the ports listed here, I have the following observations:
Port 8092 returns: {"couchdb":"Welcome"}
Ports 21100/21200/21300 hang for exactly 7 seconds and then give an empty reply
Port 4369 gives an empty reply immediately
Every other port listed (including the important 8091) gives “Connection refused” (or “Connection reset by peer” when exposed thru docker)

I would upload various log files, but this forum software doesn’t allow me. They are mostly filled with the same warning messages about various internal services failing to connect to http endpoints, for example:

./error.log:[ns_server:error,2022-05-21T11:26:22.088Z,ns_1@cb.local:ns_server_stats<0.7156.23>:ns_server_stats:handle_info:370]Received exit_status 1 from sigar

./error.log:[ns_server:error,2022-05-21T11:26:22.085Z,ns_1@cb.local:<0.7135.23>:prometheus:post_async:192]Prometheus http request failed: URL: Body: <omitted> Reason: {failed_connect,[{to_address,{"",9123}}, {inet,[inet],econnrefused}]}

./goxdcr.log:2022-05-21T10:28:29.396Z ERRO GOXDCR.TopoSvc: Original REST request ( received "unknown pool" response. The URL may be incorrect or requested resource no longer exists


Of note:
I’m running Asahi Linux (ArchLinux ARM) on an M1 MacBook

If you need any additional information to diagnose this issue, please let me know.


I’m also on a Macbook Pro Max running Community Edition without issues in docker. I set up mine by doing the following:

docker pull couchbase/server:community-7.1.0-aarch64
docker run -d --name cb-71-community -p 8091-8094:8091-8094 -p 11210:11210 144b860f35ff

Note the 144b860f35ff is the image id I found by listing out my images. Once up I went through the cluster wizard and then I turned it off and on again. For my cluster, I did 1024 for data. For index and search I set them at 512. Worked without issues:

I’m not sure what’s going on with your setup. Can you share how you made your cluster?


Hi Aaron,
Thanks for your reply.

Please do note that I’m not running MacOS, I am running Asahi Linux (which is ArchLinux ARM with M1 compatibility).

I did not make a cluster as I was not able to access the web dashboard or REST api via 8091.

As for how I started the docker container, I have used both docker-compose & docker run (the same snippet you showed), to no avail.

It’s possible the fault lies with Asahi Linux / Arch Linux. Although nginx, redis & other services were able to serve web content on ports with no issue. Unfortunately with the closed-source nature of Couchbase I’m not really able to do any more digging myself.


@Moulberry I’m not sure why it wouldn’t run - technically speaking you could read the docker file in github and you would have all the information on how it is setup including dependencies:

All projects related to Couchbase source code can be found here:

It’s over 200 repos everything from our server platform to our SDKs are there. To build from source you can go to this repo:

I’m not sure what you mean about the closed source nature.


My mistake. I will do some digging and get back to you