Couchbase crashes when running "ID Lookup" from outside of network

I recently installed couchbase 2.0.1 on a modest ubuntu server in a remote datacenter. When I connect to the admin page using the global IP address and start typing into the ID lookup search box, couchbase-server will consistently crash. I do not have this issue when searching docs on my development machine (mac laptop) localhost:8091.

Does anyone have any suggestions on tracking down the appropriate error information for this situation in order to figure out what’s going on?

Below is one of the “crash reports” from the generic couchbase error log (/opt/couchbase/var/lib/couchbase/log/error.log).

=========================CRASH REPORT=========================
initial call: ns_port_server:init/1
pid: <0.6686.0>
registered_name: ns_port_memcached
exception exit: {abnormal,137}
in function gen_server:terminate/6
ancestors: [<0.6685.0>,ns_port_sup,ns_server_sup,ns_server_cluster_sup,
messages: [{‘EXIT’,#Port<0.9179>,normal}]
links: [<0.6685.0>]
dictionary: []
trap_exit: true
status: running
heap_size: 4181
stack_size: 24
reductions: 4692

[error_logger:error,2013-07-03T19:06:03.424,ns_1@<0.6.0>:ale_error_logger_handler:log_msg:76]** Generic server <0.6685.0> terminating
** Last message in was {die,{abnormal,137}}
** When Server state == {state,memcached,5000,
** Reason for termination ==
** {abnormal,137}

I believe that indicates the memcached process being managed crashed. Can you see if you have any core files generated from it?

@ingenthr, I ran “ulimit -c unlimited” and “./ /data/couchbase”, but no core files are created when I crash couchbase using the “ID Lookup” search.

I also ran “./cbworkloadgen -n localhost:8091 -i 500000 -r .2 -s 1” in order to stress the node and couchbase remained stable during the stress test. This crash only seems to happen when using the ID lookup.

jonathonl, I have the same issue. I hoped that updating version of server from 2.0.1 to 2.1.0 will help but the problem is not decided.
I informed about this problem at bugtracker Maybe you can add useful information

I think it’s due to low physical memory. The problem was happening on single server setups with 2 gigs of ram. The crashing did not occur on a single server setup with 4 gigs (minimum requirement btw). Adding a second 2gb node solved the problem with the smaller machines.

Problem occurred on a machine with only 2 GB RAM. After increasing the RAM to 8 GB problem was solved


This error was due to an under-sized cluster.

As you can see in the system requirements, the minimal physical RAM is 4Gb: