Couchbase Community Edition on Openshift


We’re trying to install and use Couchbase Server Community Edition 7.1.0, and came across some errors and were hoping to resolve them

  1. We have installed Couchbase Server CE as a stateful set, on the default namespace. However, we only see 2 servers on the cluster, even though all three pods are running. We see the following error while trying to add the 3rd server manually using the UI
Failed to add node cb-1.cb.default.svc.cluster.local:8091 to cluster. Failed to connect to http://cb-1.cb.default.svc.cluster.local:8091. Could not connect to "cb-1.cb.default.svc.cluster.local" on port 8091. This could be due to an incorrect host/port combination or a firewall in place between the servers.
  1. While trying to install Couchbase Server Community Edition 7.1.0 on a different namespace, we weren’t able to access the database, even after setting the following env variable on the statefulset yaml
    value: cb-0.cb..svc.cluster.local

Is there a way to set the DNS to point to a different namespace?

Hi @rravikumar,

How are you running Couchbase on Kubernetes? Are you using the Autonomous operator?

Hi @nithishr,

No, we’re not using the Autonomous Operator, since we want to use the Community Edition. We have deployed couchbase as a statefulset
(Statefulset YAML)