Couchbase 7.1.1 fails to start on Windows server 2016 standard edition


Couchbase server v7.1.1 enterprise edition does not start on my Windows Server 2016 Standard edition. Process ElrSrv.exe fails with this error message in the System event log:

Erlang machine stopped instantly (distribution name conflict?). The service is not restarted, ignoring OnFail option.

The error appears if the windows service CouchbaseServer is configured to run with a none admin. user. If I change the service configuration to run with local system/admin user then couchbase starts successfully.

Any ideas what the error could be?

Faris Ahmed

The following is logged in babysitter.log, maybe it helps

=========================ERROR REPORT=========================
** Generic server sigar terminating
** Last message in was get_cgroups_info
** When Server state == {state,#Port<0.7>,undefined,undefined,undefined}
** Reason for termination ==
** {{sigar,1},
** Client <0.118.0> stacktrace
** [{gen,do_call,4,[{file,“gen.erl”},{line,233}]},

=========================CRASH REPORT=========================
initial call: sigar:init/1
pid: <0.126.0>
registered_name: sigar
exception exit: {sigar,1}
in function sigar:recv_data_loop/2 (src/sigar.erl, line 350)
in call from sigar:update_sigar_data/1 (src/sigar.erl, line 420)
in call from sigar:handle_call/3 (src/sigar.erl, line 97)
in call from gen_server:try_handle_call/4 (gen_server.erl, line 721)
in call from gen_server:handle_msg/6 (gen_server.erl, line 750)
ancestors: [<0.118.0>]
message_queue_len: 1
messages: [{#Port<0.7>,eof}]
links: [<0.118.0>,#Port<0.7>]
trap_exit: false
status: running
heap_size: 10958
stack_size: 29
reductions: 35567



Same error on Windows server 2022 standard with couchbase 7.1.3 enterprise.
The CouchbaseServer windows service only starts with a user that is member of the local administrators group.


erlang will crash if it is configured to run with a user that doesn’t have sufficient permissions. It needs to be able to rotate log files and also execute win32sysinfo.exe. There are issues that mention this - if you ask support, they’ll be able to provide the details.


I raised a support ticket already. But still I wonder why erlang crashes because couchbase 6.6 on Windows 2016 works as expected without admin. permissions.



Did you manage to find a fix for this issue? I am also experiencing the same when installing Couchbase 7.1.3 Enterprise in my Windows 10 laptop.

I also updated the service to use admin credentials but it still won’t start due to Erlang issue.

Hi chrispab,

Couchbase support is still investigating this issue.
At the moment I worked around this issue by running couchbase 7.1.x on Windows 10 and Windows 2022 Standard Server with local system account.



Couchbase confirmed that this “feature” is not supported! In other words, couchbase 7.x requires admin. permissions on Windows server


Thanks a lot for this info, FarisAhmed!