Couchbase 5.0.1 community indexer error


I can’t create a GSI index in a production server (windows 2012 R2).
I can create it on my own machine with Windows 10.

I can telnet to 9100-9102 and 9999.
9103-9105 return “could not open connection to host” but also on my local machine where it works fine.

We have only 1 node.

attaching logs

Found the issue (not that anyone cares or tried to help here, but just in case someone stumbles on this thread…).
When i did netstat -ab i saw that the projector was using port 9999. So i assumed it’s ok.
But it wasn’t.

ngnix was also using it for OUTBOUND communications which didn’t show up in netstat.
once i changed Couchbase’s port the issue was resolved.


I am glad that you are able to resolve the issue by your own. Apologies from our side for not responding soon enough. Going forward, if you did not get any response soon enough, please ping on the issue so that we can prioritise the issue.

As a future reference, the list of ports that must be open and available for couchbase functionality are documented at:


Hi @varun.velamuri,

I’m still having issues.
After changing the projector port, I was finally able to create the GSI index on the machine, but I am unable to use it.
Couchbase is throwing a panic error when I try to run a DELETE statement.

I have a Couchbase type bucket. Lets call it bucketA

I created an index:
CREATE INDEX SCindex on bucketA (META().id)

I try to run a select and I get this:

I try to run a delete and I get this:

I try to run a delete from the .NET SDK ( and the request hangs until my http request times out.

Here are relevant logs:



Your select statement should be

select meta().id from users_couchbase where meta().id is not null

Regarding the second query, there is a space between META and (). Also, the right side of like expression should be encapsulated in single/double quotes

delete from users_couchbase where meta().id like ‘%UserID_1%’

Having said that, the panic is coming from query process. @vsr1 Can you please shed some light on the panic


The query panic might have fixed in latest versions. Did you try with 6.x CE version

@vsr1, No I haven’t.
Our product is an Enterprise product and we do a lot of QA, so just upgrading Couchbase is something that’s going to require much testing. It’s not something we can just do on a production environment of a customer.

I can upgrade just for the sake of testing, but it would help to know what is this issue and if it’s a known issue with Couchbase 5.01

@vsr1, I’ve installed Couchbase 6.0 CE.

When I run the DELETE request now, it doesn’t throw the error but the request hangs endlessly.
Attaching new logs.

Check the mutations in UI see if delete is happening.
You can also Do with LIMIT 1000 and see if it working. If need repeat command

The delete doesn’t happen.
The bucket is almost empty. it has 2 documents so no point to do LIMIT 1000

the query.log i attached shows there is some i/o timeout for some reason communicating with 9101, but before that it shows that the connection was created successfully on 9101…

Apparently that was another slippery process trying to use 9101 even though Couchbase has successfully attached itself to it. Changed the port and problem was solved.

Good to know that alon. Full list of ports used by Couchbase Server can be found in


I know which ports are used by Couchbase, it just can be tricky finding out which of them are available at any given time