Couchbase 4.0 on Oracle Linux 7.2


I’m trying to install couchbase 4.0 on an Oracle Linux server. After installation, it says the following

Starting couchbase-server (via systemctl): Failed to start couchbase-server.service: Unit couchbase-server.service failed to load: No such file or directory.

So, after following this (Centos 7 couchbase server cannot start the service), I tried the command “sudo /opt/couchbase/etc/couchbase_init.d start”.

It says “Starting couchbase-server-community” and the command just stopped. When I checked “sudo /opt/couchbase/etc/couchbase_init.d status”, it keeps saying “couchbase-server-community is not running”.

I’ve also tried “curl http://localhost:8091” but it seems like nothing is listening there (“connection refused”).

May I know that it is a known problem couchbase is not supported on Oracle Linux 7 ? Or there might be another workaround to make it work? I’d appreciate if someone can point me out. Thanks.

As per the Installation Guide, Oracle Linux 7.x is not a supported platform - the newest supported version Oracle Linux for CB Server 4.0 is 6.

Yes, that’s right as DaveR mentioned we don’t support Oracle Linux 7 currently. You can find all the supported platforms here. I have created a JIRA issue MB-19044 to track it.
Anil Kumar


Are there any news about the support of Oracle Linux 7 ?

I’d like to push in my organization the usage of Couchbase by testing the last realease. But, all our servers provided by IT team use Oracle Linux 7.3 :confused: