Couchbase 4.0 and 4.1 is not working on Windows 10 64-bit

I am trying to install CB 4.0/4.1 CE on my Windows 10 machine. I am observing the following:

  1. After installation I get this error message stating - Looks like Couchbase Server does not respond in time. Please manually refresh browser and wait for the admin console to fully start.
  2. I find CB in STOPPED state. I make it run and again after sometime it gets stopped.
  3. But even when its running, 8091 port is not in use(CBError.png). There is nothing running on 8091 and firewall is also disabled.

    How will admin console will come up while nothing is running on 8091?

This is pretty disappointing. :frowning:

This is the first enthu killer for someone who is planning to give a try to CB.

1 Like

Having same issue here. Bump.

Sorry for the delay folks, let me ask @anil to see if he can follow up or pass this along. I think to diagnose, we’d need a cbcollect_info. Can either of you generate one and then either file an issue with it attached or mention where we can get it?

My apologies for delayed response. I have filled an issue in our JIRA MB-17513 I believe its the same issue.

Can either one of you collect logs using cbcollect_info and attach that to MB-17513 that will be great.


Hi Guys,

As it was getting late, I did reset my Windows 10 and then it worked in one shot. So I am not sure what was wrong. But what so ever was wrong if it had created a log file in standard way, life would have been easier. I am very sorry that I do not have chance to reproduce the error for you to understand the bug.


Thank you for update Abhideep. Yes server does create a log file and the tool cbcollect_info I mentioned will collect all those log files for debugging. But since you have already reset you might have lost all the log files now. In any case we are still running multiple scenarios to reproduce this issue.


It seems that it took it a while before the console became available. Apparently, after install it does not respond immediately. Unfortunately, I left it overnight and the next morning it seemed to be working.

I certainly dint try to leave it for over night :o . this can be disappointing to new adopters. No one would think of it.

This is interesting. I do deployments to windows server and windows client quite often on Azure on IaaS and I don’t experience the issue. Could you share the exact version of windows you are experiencing this so I can try this out?

I can think of something going wrong in the OS, may be. Here is the OS version story:

I bought Windows 8 Pro. That got a free update of 8.1. Then I installed VMWare for virtualization and was running a CentOS on a VM. Then I got Windows 10 update, sometime during that update it warned me that VMWare might not work correctly after update. I ignored that. Later I realized VMWare is actually getting terminated with some error. My idea was to run the CB on CentOS VM. But then I thought I can directly run it on Windows. So I installed and was facing these issues. I felt Windows 10 is killing it. So I thought of formatting the OS. But I gave it one more chance and thought of resetting the OS to factory defaults. I decided if that also fails I will go back to Windows 8.1, because Oracle VirtualBox was not so comfortable. But after reset it worked.

I will try installing it on Azure IaaS. Should I use A3 or D3 machine on Azure ?


Tried installing CB on CentOS 6.7 on Google Cloud. Didnt work there also. Whats wrong with CB? Why it does not come up smoothly?

[abhideepchakravarty2@fscb ~]$ wget http://
–2016-02-14 05:52:02-- http://
Connecting to||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 74037668 (71M) [application/x-redhat-package-manager]
Saving to: “couchbase-server-enterprise-4.1.0-centos7.x86_64.rpm”
100%[==============================================================================================================================================================>] 74,037,668 37.9M/s in 1.9s
2016-02-14 05:52:04 (37.9 MB/s) - “couchbase-server-enterprise-4.1.0-centos7.x86_64.rpm” saved [74037668/74037668]
[abhideepchakravarty2@fscb ~]$ sudo yum install couchbase-server-enterprise-4.1.0-centos7.x86_64.rpm
Loaded plugins: fastestmirror, security
Setting up Install Process
Examining couchbase-server-enterprise-4.1.0-centos7.x86_64.rpm: couchbase-server-4.1.0-5005.x86_64
Marking couchbase-server-enterprise-4.1.0-centos7.x86_64.rpm to be installed
Determining fastest mirrors

  • base:
  • extras:
  • updates:
    base | 3.7 kB 00:00
    base/primary_db | 4.6 MB 00:00
    extras | 3.4 kB 00:00
    extras/primary_db | 34 kB 00:00
    scl | 2.9 kB 00:00
    scl/primary_db | 366 kB 00:00
    updates | 3.4 kB 00:00
    updates/primary_db | 3.9 MB 00:00
    Resolving Dependencies
    –> Running transaction check
    —> Package couchbase-server.x86_64 0:4.1.0-5005 will be installed
    –> Finished Dependency Resolution
    Dependencies Resolved
    Package Arch Version Repository Size
    couchbase-server x86_64 4.1.0-5005 /couchbase-server-enterprise-4.1.0-centos7.x86_64 202 M
    Transaction Summary
    Install 1 Package(s)
    Total size: 202 M
    Installed size: 202 M
    Is this ok [y/N]: y
    Downloading Packages:
    Running rpm_check_debug
    Running Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Warning: Transparent hugepages looks to be active and should not be.
    Please look at http:// as for how to PERMANENTLY alter this setting.
    Warning: Transparent hugepages looks to be active and should not be.
    Please look at http:// as for how to PERMANENTLY alter this setting.
    Warning: Swappiness is not set to 0.
    Please look at http:// as for how to PERMANENTLY alter this setting.
    Minimum RAM required : 4 GB
    System RAM configured : 14.59 GB

Minimum number of processors required : 4 cores
Number of processors on the system : 4 cores

Installing : couchbase-server-4.1.0-5005.x86_64 1/1
Starting couchbase-server

You have successfully installed Couchbase Server.
Please browse to http:// fscb:8091/ to configure your server.
Please refer to http:// for additional resources.

Please note that you have to update your firewall configuration to
allow connections to the following ports: 11211, 11210, 11209, 4369,
8091, 8092, 8093, 9100 to 9105, 9998, 18091, 18092, 11214, 11215 and
from 21100 to 21299.

By using this software you agree to the End User License Agreement.
See /opt/couchbase/LICENSE.txt.

Verifying : couchbase-server-4.1.0-5005.x86_64 1/1

couchbase-server.x86_64 0:4.1.0-5005

[abhideepchakravarty2@fscb ~]$ netstat -an | grep 8091
[abhideepchakravarty2@fscb ~]$ sudo service couchabse-serve status
couchabse-serve: unrecognized service
[abhideepchakravarty2@fscb ~]$ sudo service couchbase-serve status
couchbase-serve: unrecognized service
[abhideepchakravarty2@fscb ~]$ sudo service couchbase-server status
couchbase-server is not running
[abhideepchakravarty2@fscb ~]$ sudo service couchbase-server start
Starting couchbase-server

[abhideepchakravarty2@fscb ~]$ sudo service couchbase-server status
couchbase-server is not running
[abhideepchakravarty2@fscb ~]$

I did try install Couchbase Sever 4.0.0 Community Edition on Windows 10 Pro. Everything works as expected. After the installation is done, a browser is up at initialization page asking user to initialize Couchbase Server.
Here is the screen shot from this installation

The installation is also ok for Couchbase Sever 4.1.0 Community Edition on Windows 10
Pro. Everything works as expected. After the installation is done, a
browser is up at initialization page asking user to initialize Couchbase
Here is the screen shot from this installation

I ran into the same issue on Windows 7 here Windows Service startup fails

I don’t deny because it worked for me when I did reset on my machine. The point is when it failed, it failed and fails silently. If it says something, we can exactly point out the problem. I am thankful for your effort and time. Really appreciate it.

I have same exact problem on Windows 10 64-bit and Couchbase 4.1 Community (latest).

Installation File: couchbase-server-community_4.1.0-windows_amd64.exe

Here’s my

Please help, thanks.

I’m having the same issue, however, after uninstalling and reinstalling several times (installed to C:\ after reading that spaces in the path when installing to the default c:\program files\ can be a problem on windows.) Unfortunately the admin console still doesn’t work - switching the port to 8092 gives the following error:

"code": 404,
"status": "fail",
"message": "controller_not_provided",
"ResultDate": "2016-09-02T06:30:18.3350237Z",
"Progress": -1,
"Result": "No controller provided."

I am also unable to install the couchbase module via npm:

npm ERR! Failed at the couchbase@2.2.2 install script 'prebuild --install'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the couchbase package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     prebuild --install

I attempted to file an issue through the npm repo but there is no option to actually create a ticket when you follow the link from the npm page.

This is disappointing, I attended a Node/Angular2/CouchDB meetup this week and was unable to use couchbase. MongoDB installs painlessly on my machine. I’m running Windows 10 Insider Preview build 14905, Node v6.3 and npm 3.1.

1 Like

A similar issue is happening to me while installing couchbase on a Docker container… Are there any solutions?

@manusyone and @blakehschwartz,

Are either of you still experiencing problems? There was an issue with Windows 10 Anniversary Edition at some point, but that has been taken care of (see: If there’s anything I can do to help, please let me know.

I found the work around. Be it installation or uninstallation, restart the Windows and things will be fine. Install and start using, wont work. Install -> Restart Windows -> Use CB.