Couchbase 2.1.0, 2.1.1 freeze on upgrade on Windows

Hello. Earlier I’ve tried to upgrade my couchbase from 2.0.1 to 2.1.0 and installation process stuck at “Computing space requirements” at the end of installation. Then I was unable to do anything with install and killed install process. Then I reinstalled couchbase - all good, except all data was lost. Now I’ve tried to upgrade 2.1.0 version to 2.1.1 and got the same problem.

  • After install process termination couchbase windows service is not installed. May be there are some problems with installing that service.

  • In windows logs MSI installer writes that “Couchbase Server – Installation operation completed successfully.” But when I try to use some utils from bin folder I get such error:

    C:\Program Files\Couchbase\Server\bin>ip_addr.bat
    Could not load module C:\erl5.8.5.cb1\erts-5.8.5.cb1\bin\erlexec.dll.

    And erl5.8.5.cb1 floder is inside C:\Program Files\Couchbase\Server, not C:\

Cluster configuration: One Windows x86_64 server, 35Gbytes free on HDD.
All services that access couchbase were stopped before upgrade.

Have you tested with after a reboot (and keep Couchbase stopped) ? (just a test not a real solution…)

No. I didn’t try reboot server (it’s test server, but in that moment it performed some valuable operations, but they couldn’t affect installation). I’ve tried several times to install it, with uninstallation through windows control panel, just “rm -rf” all couchbase folders, with “Run as administrator” and without it, but nothing helped. All folders have correct write permissions.

I’ll try to reboot that test server tomorrow and write if it installs correctly. By the way we have another test server with same configuration (CPU, memory, etc.) and we performed upgrade from 2.0.0 CE to 2.1.0 EE and it was successful.

Reboot not helped.

Before upgrade, please shutdown any browsers such as explorer, firefox and chrome. It is possible that some window runtime libraries are used by these processes and Couchbase installer tries to check and update files.

I’ve tried many ways. Even after reboot (without starting anything like browsers). The result was the same - freeze at the end of install.