Constant warnings of "Approaching low index resident percentage" with plenty of RAM

We keep getting the “Warning: approaching low index resident percentage. Indexer RAM percentage on node “127.0.0.1” is 0%, which is under the threshold of 10%” message on our Couchbase 7.2.2 CE system.

Alert

This is despite our server having plenty of RAM (32GB total, 20 GB allocated to Couchbase) and none of the memory usage in Couchbase reporting low:







Why might this be happening, where should I look? Or is this just a useless warning that I can ignore.

If it can be safely ignored, is there a way to disable it?

Setting > Alerts
I think unchecking the ‘Approaching Indexer low resident percentage, ui popup’ will prevent the popup from appearing.

OK, thanks. But should I disable it? Is it important? Am I just covering up an issue that should be corrected?

I don’t see any settings for “Alerts”. We are on the Community Edition, maybe that’s an Enterprise Edition setting?

Alerts | Couchbase Docs

I believe that the message is being generated because the current resident percentage is 0%.

The message itself states this, and the second screenshot also shows 0%.

CE (Forestdb) does not have the logic to calculate resident ratio statistics.

Reference: [MB-44400] [CE] Index resident ratio shown as 0% for all indexes - Couchbase database

It doesn’t look like there’s a problem.

Ok, thank you. Good to know it’s not a problem. Hopefully I can find somewhere else to disable the message since I don’t appear to have the control in the Web Console GUI.

OK, I figured out how disable the alert via the Couchbase API.

Can you tell how? We are experiencing the same problem. Also on CE.

Here is the Couchbase REST API for alerts -