Cluster creation goes wrong with couchbase 7 on Buster

Hi ,
when I set up a new couchbase server on Debian Buster, I can’t complete the cluster setup via http .

I receive a generic error at the end :

’ Unexpected server error, request logged.’

If I also try to set up a new cluster via cli command (), I receive the following error:
‘ERROR: Internal server error, please retry your request’
I use a similar command syntax:

couchbase-cli cluster-init -c 10.x.y.z --cluster-username username  --cluster-password userpassword  --services data,index  --cluster-ramsize 8192 --cluster-index-ramsize 2048

The problem only appears with couchbase-server 7.x releases . The cluster setup works out well with the 6.6.x releases on the same servers .

Just tried couchbase-cli cluster-init on Debian 10 with Couchbase 7.0.1 Enterprise – worked fine for me. Maybe the logs will have more info/clues about the error you are seeing – look at the info.log or the debug.log in /opt/couchbase/var/lib/couchbase/logs .

1 Like

Thank you,
By looking at the two files which you have suggested , the issue seems related to the memcached misconfiguration,
Here a debug.log extract:

[ns_server:warn,2021-09-13T09:26:19.302Z,ns_1@10.xx.y.zz:memcached_refresh<0.269.0>:ns_memcached:connect:1202]Unable to connect: {error,{badmatch,[{inet,{error,econnrefused}}]}}.
[ns_server:debug,2021-09-13T09:26:19.302Z,ns_1@10.xx.yy.zz:memcached_refresh<0.269.0>:memcached_refresh:handle_info:87]Refresh of [ssl_certs,rbac,isasl] failed. Retry in 1000 ms.

 but I have not solved out yet.

Looking better at the messages in the log files, I have seen an error like that:

memcached.log.000001.txt:2021-09-09T18:37:33.063209+00:00 CRITICAL Failed to initialise - CPU with SSE4.2 extensions is required - terminating.

This error is related to the missing sse4_2 cpu flags . Since I installed the couchbase server on a virtual machine , the issue has been solved out by changing the VM processor type, to one that could use the sse4_2 flags , instead of the generic one previously set. So , once the VM has been restarted, a cpuinfo reported the cpu missed flag:

cat /proc/cpuinfo
model name	: Intel Xeon Processor (Skylake)
flags		:  fpu  .................... pclmulqdq ssse3 fma cx16 pcid sse4_1   sse4_2   x2apic movbe popcnt .............

After that , I managed to start the cluster and join other nodes to it