Can't seem to get php sdk installed on ubuntu 15

I’ve tried a few different things to get the PHP SDK installed on my box. This is literally day two for me with Couchbase, so I apologize in advance for any noob mistakes / questions.
I’ve attempted to install PHP SDK 2.0/2.1 but whenever I try my test web page, I get the following error:

Fatal error: Class ‘CouchbaseCluster’ not found in /var/www/html/phonesys/test.php on line 10

Line 10 looks like this:
$cluster = new CouchbaseCluster();

Here’s what I’ve done:

  1. Make sure to remove the older sdk i attempted:
    me@mydev:/var/www/html/phonesys$ sudo pecl uninstall couchbase-1.2.2
    Unable to remove “” from php.ini
    uninstall ok: channel://

  2. Install the latest sdk:
    me@mydev:/var/www/html/phonesys$ sudo pecl install couchbase

    Build process completed successfully
    Installing '/usr/lib/php5/20131226/’
    install ok: channel://
    configuration option “php_ini” is not set to php.ini location
    You should add “” to php.ini

I then ensured that i have the extension defined in my /etc/php5/apache2/php.ini file.
Then I restart apache.

What am I missing?
Any help would be appreciated.

I just updated /etc/php5/cli/php.ini as well with
and restarted apache… and now it’s happy.
not sure why i have to update the cli version when I’m browsing to my test page…
but it’s happier.

Hello Wooj.

  1. $bucket = new CouchbaseCluster(“”, “Administrator”, “Passw”, “default”);
  2. $bucket->openBucket(“test”);

yeah thanks Kozlov. I actually got it working. but thanks very much for taking the time to respond. much appreciated.