Can't query buckets ... segment fault 11

I had been using Couchbase 2.0.1 on my home and laptop computers (both OSX 10.8.5) with no problem for many months and then suddenly my laptop stopped working. Specifically the ability to use PHP to get or set documents in buckets started returning a “segment fault 11”.

In the hope that maybe the latest and greatest Couchbase version would solve this I tried both 2.1 and 2.2 builds of Couchbase Server with exactly the same results. Furthermore, I also went so far as to do a complete clean install of Couchbase. I then manually added in the appropriate buckets and then ran a cbrestore to pull the data in. This operation all worked fine, the admin panel shows all the data there, going into the document is fine, everything looks good. This makes me believe there is something wrong with the PHP client library but I’m not really sure what to think.

I’m using the latest version of the PHP client library (1.2.1) but I had the same problems with the prior stable build (1.1.5) which is what I’m still using on my home computer with zero problems.

I’m desperate to get some help on this as this has me completely stuck. Any help would be greatly appreciated!

Oh also, for what it’s worth I have the latest C libraries too (v2.1.1). This is consistent across both laptop (doesn’t work) and home computer (works).

Finally, I forgot to mention that the PHP library DOES allow me to successfully run view queries and get the results back. It’s only when trying to work with get/set/etc. for the bucket documents that things fail with the “segment fault 11”.

Hi There,

I have tried to replicate your issue, as I too am using the same versions of the PHP SDK and C SDK on the same OS, but I can’t seem to replicate the issue.

In your question did you mention that is DOES work on your home computer, but DOES NOT work on your laptop?

I have also asked a member of our PSP SDK team to take a look at this.



Yes it works on my iMac at home but not my MBP although it DID work on both but suddenly developed this problem on my laptop. I can’t remember anything changing to create this problem and I certainly would have thought a clean reinstall would solve the problem (although possibly I didn’t clear everything from the state machine?).

It’s a bit baffling as from the admin panel everything appears it’s working. That leads me to believe that it was a PHP/C library issue but that definitely did not change between when it was working and now when it is not. Admittedly in this process I have upgraded the PHP client to the latest rev as well as the couchbase server but this appears to have no effect.

Is there any other information I can give you that would be helpful?

Have you got the same XCode Developer Tools installed on both machines, and more importantly the same GCC compiler packages?

I’m not sure whether that is a longshot, but it could be a discrepancy there.

could you also get backtraces?

Ok the gcc question first … my laptop and home computer appear to both have:

gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.11.00)

That assumption is based on just running gcc -v from the terminal. I did a locate gcc too just to see if maybe there were other versions out there and as I’m sure no surprise to you there were tons of gcc references but nothing jumped off the page at me and the results seemed very consistent on both machines.

Now regarding xcode I found them both to be running the same version:

Version 5.0 (5A1413)
When I fired up xcode they both required me to sign-off on the new terms of service which seems to indicate that they both upgraded themselves fairly recently which sounds right to me ... undoubtedly an IOS7 thing and yet I don't think the timing of this matches up with when my laptop started having its problems.

Finally, regarding backtraces … I’m happy to do this but looking at the two links I was still a little uncertain how to do this effectively for couchbase on OSX. Can you give me a little more instruction on how best to capture this?