-bash: cbdocloader: command not found

Hi ,

I recently started learning couchbase . So I installed couchbase server in my MAC and trying to upload the document as per the instructions given in the CB110-lab-workbook-4.5 but I am getting the below error. Could you please help me to resolve the issue.

$ cbdocloader ­u Administrator ­p password ­n ­b couchmusic2 ­s 512 CB110-Data/couchmusic2-userprofile.zip
-bash: cbdocloader: command not found

Please let me know if you need further details .


Can you look in /Applications/Couchbase Server.app/Contents/Resources/couchbase-core/bin/ and see if cbdocloader is there?

@matthew.groves - Hi Matthew, I am also facing the same issue but my couchbase server in installed on centos 7. I have checked under /opt/couchbase/bin folder and found that cbdocloader is present.
Still when i am using the command:
cbdocloader -n localhost -u -p -b ChecklistLibrary /opt/couchbase/bin/ChecklistLibrary.json
I am getting the same error: "-bash: cbdocloader: command not found"

Please suggest what needs to be done. Let me know if you need any further details.

Hi @esita.banerjee,

I don’t have a centos VM, but I’m trying it in a Couchbase Server Enterprise 4.5.1 docker image (which uses ubuntu, I believe) and it seems to be working fine.

Are you running that command from within the /opt/couchbase/bin folder? Are you using 4.5.1 Enterprise or another version?

@matthew.groves - I am using 4.5.1 Enterprise version and I am not running couchbase through docker. And yes I am running the command from within the /opt/couchbase/bin folder.

Is this any issue with centos VM? Even the cbimport,cbexport,ebtransfer,cbrestore none of the commands are running. I am getting the same error for all the commands.

But I can access couchbase console and cbq command also.

Seems like this problem has been solved in another thread: Replicate existing cluster's documents in new cluster - getting error: "Bash cbimport command not found"

Ya the problem is solved. The commands worked with /opt/couchbase/bin/ before the actual cbimport,cbexport,cbdocloader or the other commands.