How to use "cbdocloader" for importing json docs into a cluster?

Hello all,

I want to import large number of json documents into existing cluster. Here is the cluster information (all nodes are for Data/Index/Query) :

I have tried “cbdocloader” but it does nothing. All json docs are kept at “C:\docs” path. While I am executing cbdocloader -­u Administrator -­p Welcome1 ­-n localhost:8091 -­b couchmusic2 -­s 512 “C:\docs” from windows pc, it gives below message.

Am I doing any syntax mistake or what?

Note: I am running the command from PC1 (from above list), I have tried the same command by replacing IP address with,, localhost etc. Also I have tried the same with and without proxy settings.

Can anyone please help me to solve it out?


Lol…!! :joy:

Actually I have copied above command from document’s pdf’s example, pasted it on notepad, edited as per requirement and the updated command copied and pasted in cmd. Which does not work (as per above).
But I tried to type the same command and it works perfectly…!!!

No mistakes in syntax or file path or any options, just copy makes some problem. (Of course, command works without proxy only) And it did not happen once, I have reproduce the same.

Strange but ture…!! :wink:

Thanks :slight_smile:

Sometimes when you copy/paste, quotation marks get converted from regular quotes to “smart quotes” that are angled differently, and are a different character. Is it possible that the quote marks around C:\docs got converted to the wrong form?

Yes, it can be possible. But in my case, quotation marks was not the problem as I have typed it manually. But “Hyphen” was converted to some special character, which was creating problem.

I have checked the same by preparing an HTML file having both (working and non working) commands, and opening it into browser (as shown below).


I’m glad you found the solution! Those unicode characters can cause lots of trouble when the look just like traditional ASCII.