Backup/restore about index and FTS

I’m the beginner about Couchbase.
For deployment, I’m making a script to migrate couchbase settings onto other couchbase: backup index/FTS and some data and restore it onto other couchbase.

Just to test it from my local(docker), I ran backup like below:

./cbbackupmgr config -a ~/data/backup -r frontend-transactions --disable-gsi-indexes --disable-data --disable-cluster-analytics --disable-analytics --disable-eventing --disable-bucket-query --disable-cluster-query
./cbbackupmgr backup -c localhost -u '***' -p '***' -a ~/data/backup -r frontend-transactions

But I found it doesn’t make index backup

-      Bucket   | Size  | Items | Mutations | Tombstones | Views | FTS | Indexes | CBAS |
-      mybucket | 1012B | 0     | 0         | 0          | 0     | 1   | 0       | 0    |

So I tried without ‘–disable-gsi-indexes’

./cbbackupmgr config -a ~/data/backup -r frontend-transactions --disable-data --disable-cluster-analytics --disable-analytics --disable-eventing --disable-bucket-query --disable-cluster-query
./cbbackupmgr backup -c localhost -u '***' -p '***' -a ~/data/backup -r frontend-transactions

Then I got error like below:

Transferring GSI index definitions for bucket 'frontend-couchbase'                                                                                  0 items / 0B
[======================================================================================                                                                 ] 57.14%
Error backing up cluster: connection refused

Because of company permission issue, I wanna test all at my local couchbase(docker) in advance.
How can I handle this error?

Thanks for your advice! ^^

Was there an issue with FTS? It looks like you have a GSI problem only.

1 Like

If you go into your archive logs directory, ~/data/backup/logs , you’ll see the cbbackupmgr logs – there may be additional info in the logs. Since you encountered the connection refused error only after removing --disable-gsi-indexes , I am guessing that the port for accessing the Index service is not open or inaccessible in some way.

cbbackupmgr accesses the Couchbase services using the service ports – documented here. To backup (GSI) index definitions, it would be using 9102 or 19102.

1 Like

No issue with FTS (as I understood). Only GSI issue. Thanks

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.