Xamarin Android Replication Crash

I just updated my app to Xamarin Forms and as of today as well as targeting Android Q.
Now, a pull replication I have crashes the entire Android app after a few seconds. The replication starts and then fails at the same point on every emulator (LogCat information below). The exact same code runs perfectly on iOS and UWP.

Note also that based on reading other posts, that I tried changing it to PullAndPush as well and the same crash happens at the same place.

Also of note is that I am using ws: (not wss:) and thus have a network_security_config.xml file allowing clear traffic for that domain.
<?xml version="1.0" encoding="utf-8" ?> <network-security-config> <domain-config cleartextTrafficPermitted="true"> <domain includeSubdomains="true">api.mydomain.com</domain> </domain-config> </network-security-config>

Any thoughts?

12-12 08:15:35.304: A/DEBUG(5711): Build fingerprint: ‘google/sdk_gphone_x86_64/generic_x86_64:9/PSR1.180720.075/5124027:user/release-keys’
12-12 08:15:35.304: A/DEBUG(5711): Revision: ‘0’
12-12 08:15:35.304: A/DEBUG(5711): ABI: ‘x86_64’
12-12 08:15:35.304: A/DEBUG(5711): pid: 4360, tid: 4615, name: Thread-13 >>> com.redbook.mobile <<<
12-12 08:15:35.304: A/DEBUG(5711): signal 11 (SIGSEGV), code 128 (SI_KERNEL), fault addr 0x0
12-12 08:15:35.304: A/DEBUG(5711): rax b998b563ce88771c rbx 0000798075d21b70 rcx 0000000000000007 rdx 0000798077c00000
12-12 08:15:35.304: A/DEBUG(5711): r8 ffffffffffffffc0 r9 000000000000000d r10 0000798075d30d88 r11 0000798075e00000
12-12 08:15:35.304: A/DEBUG(5711): r12 0000798072ed62c0 r13 0000798073431a78 r14 0000798075d21b78 r15 0000798075dff900
12-12 08:15:35.304: A/DEBUG(5711): rdi 0000798075d30d88 rsi 0000798077de9040
12-12 08:15:35.304: A/DEBUG(5711): rbp 0000798076e5eec8 rsp 0000798072ed6280 rip 000079807326a76e
12-12 08:15:35.311: A/DEBUG(5711): backtrace:
12-12 08:15:35.311: A/DEBUG(5711): #00 pc 000000000029576e /data/app/com.redbook.mobile-zO38OojZM_ZeFK7S2sh5Zg==/lib/x86_64/libLiteCore.so (std::__ndk1::__tree<std::__ndk1::__value_type<std::__ndk1::pair<std::__ndk1::basic_string<char, std::__ndk1::char_traits, std::__ndk1::allocator>, bool>, std::__ndk1::function<void (litecore::blip::MessageIn*)>>, std::__ndk1::__map_value_compare<std::__ndk1::pair<std::__ndk1::basic_string<char, std::__ndk1::char_traits, std::__ndk1::allocator>, bool>, std::__ndk1::__map_valu
12-12 08:15:35.311: A/DEBUG(5711): #01 pc 000000000029540f /data/app/com.redbook.mobile-zO38OojZM_ZeFK7S2sh5Zg==/lib/x86_64/libLiteCore.so (litecore::blip::BLIPIO::_closed(litecore::websocket::CloseStatus)+321)
12-12 08:15:35.311: A/DEBUG(5711): #02 pc 0000000000295601 /data/app/com.redbook.mobile-zO38OojZM_ZeFK7S2sh5Zg==/lib/x86_64/libLiteCore.so (ZNSt6__ndk128__invoke_void_return_wrapperIvE6__callIJRNS_6__bindIRMN8litecore4blip6BLIPIOEFvNS4_9websocket11CloseStatusEEJPS6_RS8_EEEEEEvDpOT+59)
12-12 08:15:35.311: A/DEBUG(5711): #03 pc 000000000029d200 /data/app/com.redbook.mobile-zO38OojZM_ZeFK7S2sh5Zg==/lib/x86_64/libLiteCore.so (litecore::actor::ThreadedMailbox::safelyCall(std::__ndk1::function<void ()> const&) const+14)
12-12 08:15:35.311: A/DEBUG(5711): #04 pc 000000000029d398 /data/app/com.redbook.mobile-zO38OojZM_ZeFK7S2sh5Zg==/lib/x86_64/libLiteCore.so
12-12 08:15:35.311: A/DEBUG(5711): #05 pc 000000000029ce3f /data/app/com.redbook.mobile-zO38OojZM_ZeFK7S2sh5Zg==/lib/x86_64/libLiteCore.so (litecore::actor::ThreadedMailbox::performNextMessage()+75)
12-12 08:15:35.311: A/DEBUG(5711): #06 pc 000000000029cd7d /data/app/com.redbook.mobile-zO38OojZM_ZeFK7S2sh5Zg==/lib/x86_64/libLiteCore.so (litecore::actor::Scheduler::task(unsigned int)+109)
12-12 08:15:35.311: A/DEBUG(5711): #07 pc 000000000029d291 /data/app/com.redbook.mobile-zO38OojZM_ZeFK7S2sh5Zg==/lib/x86_64/libLiteCore.so
12-12 08:15:35.311: A/DEBUG(5711): #08 pc 0000000000092bab /system/lib64/libc.so (__pthread_start(void*)+27)
12-12 08:15:35.311: A/DEBUG(5711): #09 pc 000000000002af2d /system/lib64/libc.so (__start_thread+61)

The stack trace looks a little suspicious but is this a pull-only replication? If so, this may be a known issue that you can fix by calling the ResetCheckpoint method on your replicator. If that is the issue it has been fixed and will be in 2.7.0 (scheduled mid January)

As I mentioned I tried using a push-pull as well and got exactly the same result. I also tried calling ResetCheckpoint using the pull only with no luck.

Sorry missed that part. This only happens after upgrading Xamarin Forms? This was previously working?

@borrrden, yes, it happened after upgrading Xamarin Forms and/or targeting Android Q. It was working with Xamarin Forms targeting Android 8.1.

That trace looks familiar but I might be thinking of something else. The issue I originally jumped to only happens with pull-only replications that get into a certain state. This happens on fresh installs of an app too?

Fresh installs as well. I can spin up a new emulator (doesn’t matter when version of Android) and the crash happens.