Urgent: Strange error when entering non-English chars

using CB community edition 3.0.1
I’m getting a very strange error when trying to insert a document with a key that is consisted from English and Hebrew chars, value of the doc is JSON that contains some Hebrew.

I tried encoding it in the server, but no luck. I keep getting this weird content saved in the CB and the returned key is also Gibberished…

the key is not even saved entirely as I sent it (it’s cut after first 2 Heb characters).

Its creates a document in DB with ID like = htags::qst::4090#זז
And content like “ldeceyJ2YWx1ZSI6IteW15XXnCIsImFjY291bnRJZCI6MjAwMiwicXVlc3Rpb25JZCI6NDA”

Without Hebrew its look like htags::qst::4054#ch
{ “value”: “chain”, “questionId”: 1111, “accountId”: 1000}


Hi, could you please tell us what SDK you are using and show us the code?

Also, if this is indeed extremely urgent, you should know that our support team as excellent response time!

com.couchbase.client core-io 1.0.2 com.couchbase.client java-client 2.0.2

String lid = “htags::qst::4090#זול”;
String strData = “{“value”:“זול”,“questionId”:4090,“accountId”:2002}”;
bucket.insert(LegacyDocument.create(lid, strData));

@eladgovari this is a known issue with older versions of the client, can you please upgrade to the latest one (2.1.3) ? Then you should be good (issue identified is https://www.couchbase.com/issues/browse/JVMCBC-187)

1 Like

That’s correct @daschl - Upgrading to 2.1.3 indeed solved the problem. Thanks !

1 Like

Great it did work for you!