UpsertRequest failed with unexpected status code NO_ACCESS


Recently we started using SDK 3.0 and couch client 3.0.9. We are able to connect to the bucket and able to read the documents without any issues. But from java when we insert the document we are getting the below error

threw exception [Request processing failed; nested exception is com.couchbase.client.core.error.CouchbaseException: UpsertRequest failed with unexpected status code NO_ACCESS {“completed”…

We tried t ouse the sample provided in couch.

JsonObject arthur = JsonObject.create()
.put(“name”, “Arthur”)
.put(“email”, “”)
.put(“interests”, JsonArray.from(“Holy Grail”, “African Swallows”));

    // Store the Document

I am sure the credentials that we use to connect the couch has permissions to insert or upsert a document. I was able to add document using console using this credentials. Am I missing anything?


This issue is fixed. Weird problem with user credentails. Created new user and credentials and it started working.

Good to hear you got past it @y2k1975. It sounds like the user you were authenticating as before didn’t have permissions to write to that bucket?

1 Like

Yes for some reasons we got some problem with that user. We deleted and recreated new user credentials and it worked perfect.