Unable to get data from documents created throught SDK or directly on couchbasedb


I’m running Couchbase Lite 2.0.3 together with CouchbaseDB and GW.
All the documents are synced to Couchbase Lite and already created in CouchbaseDB.

Running the following query always returns a empty Dictionary with no keys and values for the documents created through SDK or directly on the DB server.

        using (var SearchQuery = QueryBuilder
             .Select(SelectResult.All(), SelectResult.Expression(Meta.ID))
            var results = SearchQuery.Execute().ToList();

            var entrys = results.Select(x => x.GetDictionary(0).ToDictionary(y => y.Key, y => y.Value));


The variable results count is greater than 0 and i can see that the count amount match up (compared to the bucket i sync).

Even if i run, var doc = Database.GetDocument(“Project::123”) i get an empty Dictionary with no keys and values for the documents created through SDK or direct on the DB server.

For documents created in Couchbase Lite contains a Dictionary with keys and values when using the above examples.

Is there anything i’m missing?

What do you mean by CouchbaseDB? Couchbase Server? It doesn’t look like you are missing anything but not all the information is here. Are your pull replications finishing correctly, etc?

Sorry, i mean Couchbase Server.

Yes, the replication finish without any errors.
The Bucket only contains (for now) 4 documents that i have created.

The documents looks like this:

“description”: “Description”,
“id”: “Project::d4a8530e-17a1-4f3e-bd12-d6de42cfe74b”,
“members”: [
“name”: “The Name”,
“type”: “Project”

Documents created on the Lite database get synced correctly.

I’ve never heard of anything like this, so I am not sure of what is going on. If you can reproduce it easily then I’d file a Github issue for it so that it can get examined.

Just to be sure (before posting issue), Couchbase Lite supports .Net Core 2.0 (Console Application) and .Net Standard?
Got all my logic in a .Net standard project and a Console application for presenting…

Did another test,

  1. Created a document in CBL.
  2. Start replication.
  3. The document shows up in Couchbase server.
  4. Did a query, manage to grab the dictionary from the document.
  5. Wiped the CBL database (completly removed the folder with db files).
  6. Created a new CBL database and started replicating.
  7. Did a new query, could not get the dictionary from the document. (Same result as my previous post)