Strange n1ql error number 23

When executing a n1ql query that is supposed to return data I get a very strange response back.

I get an empty error {} object and a null result.

has anyone seen this happen before?

I added some log messages inside the code in the sdk and what I am getting is an error code equal to 23. No more details.

I don’t really know what’s happening but when you connect to couchbase, you might try appending ?detailed_errcodes=1 to your connect string.

So for example you’d connect to “couchbase://localhost?detailed_errcodes=1”

This won’t fix the problem but might give you a more informative reason.

adding that did not provide me with more information. It seems to throw the error after 1 minute 15 seconds which is 75000 ms. Which is the default n1ql timeout.

is there away to increase the n1ql timeout?

You can use the Bucket.n1qlTimeout property to adjust the N1QL querying timeout.
Cheers, Brett

1 Like

Yes that timeout solved my problems. I wanna make it clear that the n1qlTimeout won’t work in version 2.1.4 of the node sdk
it only worked after I updated to version 2.1.6.

Thank you @brett19.