SSL - use private cert file rather than self signed

Couchbase ships with a default self signed certificate when installing on my local machine. I need to change the certificate to one provided by my organization. I have uploaded the certificate to the cluster using couchbase-cli ssl-manage options and I also see the certificate under Security->Root Certificate in the admin UI. But when I check the admin UI ssl icon on the chrome browser itself , it seems to be still using the original self signed certificate.

Is there something else that I need to do to ensure couchbase does not use the self signed certificate for the UI and other things and use the certificate that I need.