Pull replication is not resuming after reconnecting to a WiFi network

I’m experiencing this consistent issue where when the device disconnects from a network and connects back again the replicator (continuous) is not resuming back replication.

I’ve tried this in two ways :

  1. Going in and out of WiFi range.
  2. Turning the device WiFi off and on.

Once the network is reestablished, any pending changes ideally should get replicated to and fro, but that is not happening.

But then again if we close and relaunch the application, the replication works just fine.

Here are some more relevant details:
Device: Samsung Galaxy Tab A7
OS: Android 10
Cb Lite version: 2.8.5 (EE)
Replication type: Push & Pull, continuous

I’ve tried v2.8.4, v2.8.5, and v2.8.6, and I’m able to reproduce this behavior in all three versions. I’ve also tried the same in v2.7.0 and it seems to be working fine.

I’m hoping someone might have some insight or ideas about this issue.
Please let me know if there is any further information required from my end to investigate this issue.


(@Ajay_Koppisetty , please keep a tab on)

Network errors are a finnicky thing, so it would be useful to know exactly what exception you are running into. I know for 3.0 on Android specifically there are some improvements being worked on for this area.