PropertyReferenceException: No property saveAll found for type Dummy!

I recently started using ReactiveCouchbaseRepository (spring-data-couchbase - 3.0.0.M2, spring-boot-starter-parent - 2.0.0.M2) in one of our projects.

I referred to and setup the project but I am getting the following error.

Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'dummyRepository': Invocation of init method failed; nested exception is No property saveAll found for type Dummy!
	at ~[spring-beans-5.0.0.RC2.jar:5.0.0.RC2]
	at ~[spring-beans-5.0.0.RC2.jar:5.0.0.RC2]
	at ~[spring-beans-5.0.0.RC2.jar:5.0.0.RC2]
	at$doGetBean$0( ~[spring-beans-5.0.0.RC2.jar:5.0.0.RC2]
	at ~[spring-beans-5.0.0.RC2.jar:5.0.0.RC2]
	at ~[spring-beans-5.0.0.RC2.jar:5.0.0.RC2]
	at ~[spring-beans-5.0.0.RC2.jar:5.0.0.RC2]
	at org.springframework.beans.factory.config.DependencyDescriptor.resolveCandidate( ~[spring-beans-5.0.0.RC2.jar:5.0.0.RC2]

Here is the relevant information about setting up my project.

        <relativePath/> <!-- lookup parent from repository -->

public interface DummyRepository extends ReactiveCouchbaseSortingRepository<Dummy, String> {

public class Dummy {

    private final String id;

    private final String name;

    private final String address;
public class CouchbaseDatabaseConfig extends AbstractReactiveCouchbaseConfiguration {


Now saveAll is a repository method name and obviously that property name won’t exist in the model Dummy. Can anyone throw any light on this?

Note that when I change from ReactiveCouchbaseSortingRepository to CouchbaseRepository, the things work fine. (Of course, I also have to change reactive-ness of the code to non-reactive. But at least I am successfully able to retrieve the document from db.)

Thanks in advance, for any help. :slight_smile:

Hi @nilesh_ca,

If using spring-data-couchbase with spring-boot, the best way to add SDC dependency is by adding the starter
<dependency> <groupId>org.springframework.boot</groupId> <artifactId>spring-boot-starter-data-couchbase</artifactId> </dependency>
We have saveAll implementation for reactive repository.

Thank you @subhashni. That indeed solved the problem that I originally asked for. :slight_smile:

However, I am not sure why I get the following error.

For RxJava 1.x adapter support please add "io.reactivex:rxjava-reactive-streams": rx.Observable <~ For Flux operations
For RxJava 1.x adapter support please add "io.reactivex:rxjava-reactive-streams": rx.Single <~ For Mono operations

There is a long stacktrace which I am not putting here. But it boils down to following lines…

java.lang.IllegalArgumentException: For RxJava 1.x adapter support please add "io.reactivex:rxjava-reactive-streams": rx.Observable
at org.springframework.util.Assert.isTrue( ~[spring-core-5.0.0.RC2.jar:5.0.0.RC2]
at org.springframework.core.ReactiveAdapterRegistry.getAdapter( ~[spring-core-5.0.0.RC2.jar:5.0.0.RC2]
at org.springframework.core.ReactiveAdapterRegistry.getAdapter( ~[spring-core-5.0.0.RC2.jar:5.0.0.RC2]
at$RxJava1ObservableToFluxConverter.lambda$convert$0( ~[spring-data-commons-2.0.0.M4.jar:na]
at reactor.core.publisher.FluxDefer.subscribe( ~[reactor-core-3.1.0.M2.jar:3.1.0.M2]
Assembly trace from producer [reactor.core.publisher.FluxDefer] :

All I am doing at the concerned line (in DummyController) is repository.findAll().

I have added support for io.reactivex:rxjava-reactive-streams in its latest version - 1.2.1, but still of no use.

Do you reckon, I need to add support for something special other than these?

Thanks again in advance for your help.

Oh please ignore the next question. It seems the project did not refresh itself after i added the io.reactivex:rxjava-reactive-streams dependency.

The things are working fine. Thanks again @subhashni for your earlier help. :slight_smile:

1 Like

Hi @subhashni I encounter very similar problem so I think it’s better to ask in same thread started by nilesh_ca

I tried reactive couchbase by starting with your project

It works as expected if Repository is embedded inside main class. But when I take the Repository class out, I receive same “No property saveAll …” error

I turned off considerNestedRepositories=false and also set basePackages for EnableReactiveCouchbaseRepositories but it doesn’t help.

For normal Repository, it works just fine. Hopefully you could give some insight?

@nilesh_ca It seems that you have Repository class at top level (or at least not embedded). Do you encounter same issue as I described above?


Hi @hoahohart,

The dummy project that I used earlier, indeed has the Repository in a different package. All extra I did was to add the location of it in EnableReactiveCouchbaseRepositories. That project is (still) working fine.

However, every new project that I try to create (including the github project you have tried), with the exact similar settings to that of the dummy project (be it using, maven or gradle) indeed gives the same old problem again. And I have absolutely no clue why!

I have double checked the dependencies/settings/etc. with the working-dummy-project but could not spot any difference (apart from version been bumped from M2 to M4. Don’t know if that’s relevant though.)

@subhashni can perhaps lead us to the right cause! Till then I will use the Repository as the inner class to the Application class (thanks @hoahohart for bringing that out in light!)

Thanks for confirming the issue @nilesh_ca Yeah, for experimental purpose, inner class is fine - but it’s not flexible for real projects.

Hopefully subhashni could help us figuring out why. In the mean time, I’ll tick to the non-reactive way of accessing Couchbase

Hi @hoahohart,

Sorry about the late reply. SDC reactive kay is not fully integrated with spring-boot, the creation of beans and autowiring of the reactive repository works best on embedded now, the support for auto reactive configuration is tracked here.

Thanks for the info and the issue tracking link @subhashni