Program can't start because MSVCR110d.dll is missing on Windows 7 64bit


I tried to install c-sdk on my Windows 7 64bit machine, I got error about MSVCR110D.dll is missing. I installed Visual Studio Express 2013 for Desktop. It does not help. My machine has MRVCR110.dll , not MSVCR110D.dll.

Directory of C:\app\couchbase-client\libcouchbase-2.4.7_amd64_vc11\bin
02/16/2015 07:15 AM 167,424 cbc-pillowfight.exe
02/16/2015 07:15 AM 1,395,712 cbc-pillowfight.pdb
02/16/2015 07:15 AM 318,464 cbc.exe
02/16/2015 07:15 AM 2,550,784 cbc.pdb
02/16/2015 07:16 AM 289,280 libcouchbase.dll
02/16/2015 07:16 AM 1,723,392 libcouchbase.pdb
02/16/2015 07:15 AM 572,928 libcouchbase_d.dll
02/16/2015 07:15 AM 1,813,504 libcouchbase_d.pdb


This has been a bug for quite some time where our Windows binary executables (not the librararies) that were bundled were the debug variants (and should really have a _d suffix).

Maybe you can try downloading the VC 2012 redistributable ( which should contain that DLL. In addition, I’ve created an issue to ensure this gets fixed.

I installed VC 2012 redistributable (
I got the same error message when running cbc.
Hope this issue will be fixed soon. thanks.

The fix has been merged. You can try out this snapshot build (,MSVCC_VER=11,label=sdk_win2008_64/ws/BUILD/ and see if it works for you.

it works. thanks for your quick response.