Problem install Couchbase server enterprise 5.0.1 on windows 64 machine

I am trying to install Couchbase server enterprise 5.0.1 windows installer package on windows 64 machine and I am getting attached error.

“Couchbase Server Setup Wizard ended prematurely because of an error. Your system has not been modified.”

Hi @manoj.paduri,

Would you please run the command below to generate a log and upload the log?

msiexec /i "C:\MyPackage\Example.msi" /L*V "C:\log\example.log"

I am also seeing this error on 5.1 installer. I’ve generated a log. Where should I upload it to?

I have the same problem with 5.1.o right now, try to upload the (2.6 MB)

I am having the same issue with, attempting to install on a system with version 5.0.1-5003 already installed.

Here is the log: (1.9 MB)

the same problem for me as well
any solution?

problem solved.
worked for me but don’t know if works for everyone

  1. first you need search for regedit in windows



  2. in regedit you search for couchbase – edit->search->enter couchbase


  3. delete everything you find about couchbase except the first one(because you can not)


  4. search for couchbase again and repeat the procedure until you find nothing new (at last appear always two items)

  5. change the value of the first item and try to install again couchbase

Hope it helps

1 Like

I am having the same issues with the installation of couchbase server 6.0.1.
I have generated the log file as well but can’t upload it.
The forum says that a new user can’t upload any file.
Can u please help me?

What’s the value that you changed for the first item?

I am trying to install Couchbase 5.5.5 enterprise edition on my machine and I also get the same error. I tried cleaning up the registry however it didn’t work.

I tried to install using the command given in this thread i.e.
msiexec /i “C:\MyPackage\Example.msi” /L*V “C:\log\example.log”

I have attached the logs generated using the command for analyzing this issue.

Please let me know how to fix this, I need the DB urgently. (976.3 KB)

Thank you. This worked perfectly for me

I got to know it the hard way:
Add C:\Windows\System32 in the path variable in environment variable.
It solved for me.

I had a similar issue when trying to install 6.0.0. I think it was due to a previous couchbase installation on my machine. I was able to resolve the issue by:

  1. Opening “Registry Editor”
  2. Going to HKEY_LOCAL_MACHINE\SOFTWARE\ AND deleting the Ericsson folder.

Retried installation and it worked after that. The Ericsson folder contains “Erlang\ErlSrv\1.1\CouchbaseServer”