Problem altering an Index

I am trying to alter my index to add additional nodes and based the docs at [ALTER INDEX | Couchbase Docs](https://Couchbase Docs)

the syntax should be something like this

Alter Contacts._id WITH {“num_replica”: 2}’

but when i run it i get this error

“code”: 3000,
“msg”: “syntax error - at Contacts”,
“query”: “Alter Contacts._id WITH {"num_replica": 2}”

this is what the original Index looks like

CREATE INDEX _id ON Contacts(_id) WITH { “defer_build”:true }

INDEX keyword missing after ALTER

ALTER INDEX Contacts._id WITH {"num_replica":2, "action": "replica_count"};

When i try this…

Alter INDEX Contacts.#primary WITH {“num_replica”:2}

i still get an error

“code”: 5000,
“msg”: “GSI AlterIndex() action key missing in WITH clause”,
“query”: “Alter INDEX Contacts.#primary WITH {“num_replica”:2}”

Alter INDEX Contacts.`#primary` 
WITH {"action": "replica_count", "num_replica": 2}

Thanks so when i do alter i need the action on create its not required

@makeawish you are right. action tells what type of alter index it is.